PitBull Unit Frames 4.0

Pitbull 4 Config Menu

PitBull4 is a continuation of PitBull.

Differences from PitBull 3:

  • It's mostly done, but not entirely done thus why there are still only betas (despite this it is still very stable).
  • Documentation is written before functions
  • Much easier for third-party extensions.
  • Options will be much, much simpler. In 3.0, there's about 200 panels that you can mess with, it's overwhelming. I want to bring this down to somewhere around 10.
    • Layouts are defined deterministically and unit groups use the layout rather than ad-hoc layouts on a per-unit basis. This will make setting up your unit frames far, far easier.
    • Due to some decisions made, 4.0 is actually more configurable than 3.0. As a layout designer, you will have a lot more control over how things look. You can have different fonts on the same frame, different textures, more precise positioning, and a whole slough of other things.
  • CPU Efficiency will be taken much more seriously.
  • It uses Ace3 instead of Rock.

FAQ: http://www.wowace.com/addons/pitbull4.../faq/.

Guide: http://www.wowace.com/addons/pitbull4.../guide/.

If you want to help localize PitBull in your language, go to http://www.wowace.com/projects/pitbul.../localization/.

Forum thread: http://forums.wowace.com/showthread.php?t=15552...

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of Plinth_BWR Plinth_BWR Jul 31, 2013 at 19:35 UTC - 0 likes

    Hello! I'm having a problem getting my Tank frames working, and I'm sure it's just something I'm not configuring.

    I followed the steps in the how-to article (I did tank and tank target groups) - and this shows up properly when I have a Raid selected from the pull down menu. However, when I get into a Raid - it does not display at all. If, while in the raid, I go into the Tank group and remove the filter, setting it to show all, it does. So the group is active. (I do notice that it displays "all" in a different location, just in case that is valuable info)

    When I inspect Blizzard frames (which I don't know where to turn off ), the tanks have the shield displayed & I have specifically asked the tanks to be marked.

    So, what have I not done, that I need to do? T.I.A.

    Edit. The answer seems to be turn off the Blizzard frames in the interface by making a new profile for it and de-selecting everything. I did not remember having to do that before.

    Anyway chalk it up to user error, but you might want to update the instructions to mention it. Thank you very much. I have always enjoyed PitBull.

    Last edited Aug 07, 2013 by Plinth_BWR
  • Avatar of Stanzilla Stanzilla Jul 22, 2013 at 11:24 UTC - 1 like

    @Rustyboy: Go

    Check out the nebula169 clone, will be coming to mainline soon(TM)

  • Avatar of Stanzilla Stanzilla Jul 22, 2013 at 11:24 UTC - 0 likes

    @ghadab1: Go

    Check out the nebula169 clone, will be coming to mainline soon(TM)

  • Avatar of ghadab1 ghadab1 Apr 14, 2013 at 12:03 UTC - 0 likes

    I was wondering if pitbull 4 works in arena as unitframes or not before giving it a try.... anyone has any info about this?

  • Avatar of madindehead madindehead Apr 02, 2013 at 23:16 UTC - 0 likes

    Thanks for the green fire compatibility.

    However, I noticed something today:

    When doing a reload UI it shows as green in embers. However, after dying or zoning, it goes back to normal orange embers.

    A reload UI fixes it again.

  • Avatar of Rustyboy Rustyboy Mar 31, 2013 at 04:55 UTC - 1 like

    Any update on the availability of boss frames?

  • Avatar of Phauxe Phauxe Mar 23, 2013 at 07:19 UTC - 0 likes

    @humfras: Go

    Thanks works like a charm after fixing the event.

  • Avatar of humfras humfras Mar 21, 2013 at 12:40 UTC - 0 likes

    @Phauxe: Go

    Please ensure you have UNIT_LEVEL selected as a trigger event in the DropDown menu below the text field with your script ;)

  • Avatar of Phauxe Phauxe Mar 19, 2013 at 03:22 UTC - 0 likes

    I am using the most recent version of PitBull4 and I created a custom lua text for the player level indicator. It works and displays correctly but does not update correctly, when I level it wont update the new level, same code works fine for my target, I have to reload every level to fix it. Just in case its the code and im just missing something:

    local dr, dg, db = DifficultyColor(unit)
    return "|cff%02x%02x%02x%s|r", dr, dg, db, Level(unit)
    

    sorry if im in the wrong place. I wasnt sure if it was a ticket post for PitBull4 or I have an error with my lua post.

  • Avatar of TwilitSoul TwilitSoul Mar 14, 2013 at 17:52 UTC - 0 likes

    This is a really small feature request, but I have no idea how much effort it would take to implement it so I understand if the answer is just "no."

    I thought it would be nice if for the monk ability "Diffuse Magic", when it reverses debuffs onto their casters, the debuffs showed as being cast by the monk.

    Specifically, my debuffs have a blue border on the target, and when I Diffuse Magic an effect onto them it doesn't have a blue border.

    I'm guessing the border checks for the original source of the effect, but could it also check to see if it came from Diffuse Magic in some way?

Facts

Date created
Aug 01, 2008
Category
Last update
Aug 14, 2015
Development stage
Beta
Language
  • deDE
  • enUS
  • esES
  • esMX
  • frFR
  • koKR
  • ruRU
  • zhCN
  • zhTW
License
All Rights Reserved
Curse link
PitBull Unit Frames 4.0
Reverse relationships
4
Downloads
3,918,506
Recent files

Authors