Mousing over Minimap Icon does nothing and clikcing it only shows one mount i've never treid #423

  • MYAAAAHHHH created this issue Sep 25, 2020

    If you're reporting a problem, please ALWAYS include the following information or I won't be able to help you!  (Suggestions or feature requests need not use this template)

    • Addon version (Example: r664-alpha)
    • Did you RESTART the game after updating the addon? (Make sure to exit and close fully the client, and not just reload your UI, to detect newly-added files)
    • Steps to reproduce the error or unwanted behaviour (If the addon won't load, make sure to enable script errors!)
    • Any other information you consider relevant or helpful in solving the problem (Screenshots, expected behaviour, things you already tried to fix the issue...)

     Thank you for understanding! It's not always easy to troubleshoot problems. Please don't make it more difficult by disregarding these suggestions.

    Lua Errors in the bottom


    Basically the title, it's freshly installed, i've logged out, closed the game, reloaded, everything. Same thing is still happening. One weird thing is one of the times i tried loading the addon to check on my attempts (ive been reloading over and over on various toons) the addon printed a some of the tries on some of the bosses in my warriors chat.


    This is what appears when i click the minimap icon


    Any help is appreciated! I'm still really enw to all this so i might be doing something wrong. I've also tried disabling a few addons that i read somewhere that might interfere (eg: TSM4) but to no avail


    Message: ...rface\AddOns\Rarity\Libs\LibQTip-1.0\LibQTip-1.0.lua:1021: script ran too long
    Time: Fri Sep 25 20:05:31 2020
    Count: 1
    Stack: ...rface\AddOns\Rarity\Libs\LibQTip-1.0\LibQTip-1.0.lua:1021: script ran too long
    [string "=[C]"]: ?
    [string "@Interface\AddOns\Rarity\Libs\LibQTip-1.0\LibQTip-1.0.lua"]:1021: in function <...rface\AddOns\Rarity\Libs\LibQTip-1.0\LibQTip-1.0.lua:930>
    [string "@Interface\AddOns\Rarity\Libs\LibQTip-1.0\LibQTip-1.0.lua"]:1092: in function <...rface\AddOns\Rarity\Libs\LibQTip-1.0\LibQTip-1.0.lua:1058>
    [string "=(tail call)"]: ?
    [string "@Interface\AddOns\Rarity\Core\GUI.lua"]:1498: in function <Interface\AddOns\Rarity\Core\GUI.lua:1127>
    [string "@Interface\AddOns\Rarity\Core\GUI.lua"]:1724: in function `ShowTooltip'
    [string "@Interface\AddOns\Rarity\Core\GUI.lua"]:404: in function `OnEnter'
    [string "@Interface\AddOns\AtlasLoot\Libs\LibDBIcon-1.0\LibDBIcon-1.0.lua"]:77: in function <...ddOns\AtlasLoot\Libs\LibDBIcon-1.0\LibDBIcon-1.0.lua:60>


    Message: ...rface\AddOns\Rarity\Libs\LibQTip-1.0\LibQTip-1.0.lua:342: attempt to perform arithmetic on field '_paddingL' (a nil value)
    Time: Fri Sep 25 20:05:32 2020
    Count: 1
    Stack: ...rface\AddOns\Rarity\Libs\LibQTip-1.0\LibQTip-1.0.lua:342: attempt to perform arithmetic on field '_paddingL' (a nil value)
    [string "=[C]"]: ?
    [string "@Interface\AddOns\Rarity\Libs\LibQTip-1.0\LibQTip-1.0.lua"]:342: in function `getContentHeight'
    [string "@Interface\AddOns\Rarity\Libs\LibQTip-1.0\LibQTip-1.0.lua"]:919: in function <...rface\AddOns\Rarity\Libs\LibQTip-1.0\LibQTip-1.0.lua:865>
    [string "@Interface\AddOns\Rarity\Libs\LibQTip-1.0\LibQTip-1.0.lua"]:210: in function <...rface\AddOns\Rarity\Libs\LibQTip-1.0\LibQTip-1.0.lua:206>



  • MYAAAAHHHH edited description Sep 25, 2020
  • Cakechart posted a comment Jun 24, 2021


    Hello! This is a problem with LibQTip, the tooltip library Rarity uses to build its interface. I haven't personally encountered it, but chances are your computer or at least the WOW client might be too slow in processing the tooltip building and the game therefore stops mid-execution.


    I would suggest you go to the options menu (/rarity or Escape -> Addons -> Rarity) without opening the main window, then disable some categories or expansions so that the amount of items being loaded is lower. The problem is probably caused by the UI being too slow to load due to the amount of items Rarity is now tracking and a fix is unfortunately not simple (but we're aware).


    Edit: For some weird reason I was notified of this issue just now... ? Oh well, the response still stands.

    Edited Jun 24, 2021

To post a comment, please login or register a new account.