AzeriteEmpoweredItem Error #1039


  • Fixed
Open
  • Abraxis_Endrane created this issue Sep 22, 2018

    I have never posted an error report before for WoW, since 99% of the time it sorts itself out via update or I can find someone else with the same issue that resolved it with a bit of Google-Fu...but not this time, so I apologize if I'm missing anything.

     

    I have no idea what it causing it or how to fix it. But with the recent update to AtlasLoot (8.08.00) I keep getting this error whenever I click on any of the Tier set listings within the addon itself.  

    Date: 2018-09-22 10:44:41
    ID: 1
    Error occured in: Global
    Count: 1
    Message: Usage: local isAzeriteEmpoweredItem = C_AzeriteEmpoweredItem.IsAzeriteEmpoweredItemByID(itemInfo)
    Debug:
    [C]: ?
    AtlasLoot\Button\Item_type.lua:60: OnSet()
    AtlasLoot\Button\Button.lua:529: SetSecType()
    AtlasLoot\Button\Button.lua:513: SetType()
    AtlasLoot\GUI\SetViewFrame.lua:180: SetItem()
    AtlasLoot\GUI\SetViewFrame.lua:369:
    AtlasLoot\GUI\SetViewFrame.lua:352
    AtlasLoot\GUI\SetViewFrame.lua:467: OnItemInfoFinish()
    AtlasLoot\Core\ItemQuery.lua:34: OnEvent()
    AtlasLoot\Core\ItemQuery.lua:94: AddItemInfoList()
    AtlasLoot\GUI\SetViewFrame.lua:538: RefreshAtlasLootSet()
    AtlasLoot\GUI\SetViewFrame.lua:557: SetAtlasLootItemSet()
    AtlasLoot\Button\Set_type.lua:88: OnMouseAction()
    AtlasLoot\Button\Button.lua:98:
    AtlasLoot\Button\Button.lua:90
    Locals:
    (*temporary) = "Usage: local isAzeriteEmpoweredItem = C_AzeriteEmpoweredItem.IsAzeriteEmpoweredItemByID(itemInfo)"

    AddOns:
    KalielsTracker, v3.1.1
    Swatter, v8.0.6162 (SwimmingSeadragon)
    AddOnSkins, v3.93
    Altoholic, vr190
    ArkInventory, v30813
    ArkInventoryRules, v10200
    ArkInventoryRulesExample, v10000
    ArkInventorySearch, v10200
    Atlas, vv1.44.03
    AtlasBattlegrounds, vv1.44.00
    AtlasBurningCrusade, vv1.44.00
    AtlasCataclysm, vv1.44.00
    AtlasClassicWoW, vv1.44.00
    AtlasClassOrderHalls, vv1.44.00
    AtlasDungeonLocs, vv1.44.00
    AtlasLegion, vv1.44.00
    AtlasMistsofPandaria, vv1.44.00
    AtlasOutdoorRaids, vv1.44.00
    AtlasScenarios, vv1.44.00
    AtlasTransportation, vv1.44.00
    AtlasWarlordsofDraenor, vv1.44.00
    AtlasWrathoftheLichKing, vv1.44.00
    AtlasLoot, vv8.08.00
    AtlasLootBattleforAzeroth, vv8.08.00
    AtlasLootBurningCrusade, vv8.08.00
    AtlasLootCataclysm, vv8.08.00
    AtlasLootClasses, vv3.1
    AtlasLootClassic, vv8.08.00
    AtlasLootCollections, vv8.08.00
    AtlasLootLegion, vv8.08.00
    AtlasLootMistsofPandaria, vv8.08.00
    AtlasLootWarlordsofDraenor, vv8.08.00
    AtlasLootWrathoftheLichKing, vv8.08.00
    AtlasMajorCitiesEnhanced, vv1.16
    AucAdvanced, v8.0.6122 (SwimmingSeadragon)
    AucFilterBasic, v8.0.6149 (SwimmingSeadragon)
    AucStatHistogram, v8.0.6151 (SwimmingSeadragon)
    AucStatiLevel, v8.0.6155 (SwimmingSeadragon)
    AucStatPurchased, v8.0.6152 (SwimmingSeadragon)
    AucStatSimple, v8.0.6153 (SwimmingSeadragon)
    AucStatStdDev, v8.0.6154 (SwimmingSeadragon)
    AucUtilFixAH, v8.0.6156 (SwimmingSeadragon)
    BeanCounter, v8.0.6157 (SwimmingSeadragon)
    DataStore, vr65
    DataStoreAchievements, vr47
    DataStoreAgenda, vr29
    DataStoreAuctions, vr50
    DataStoreCharacters, vr43
    DataStoreContainers, vr59
    DataStoreCrafts, vr82
    DataStoreCurrencies, vr38
    DataStoreGarrisons, vr24
    DataStoreInventory, vr53
    DataStoreMails, vr52
    DataStorePets, vr44
    DataStoreQuests, vr46
    DataStoreReputations, vr43
    DataStoreSpells, vr32
    DataStoreStats, vr31
    DataStoreTalents, vr61
    DBMCore, v8.0.10
    DBMDefaultSkin, v
    DBMStatusBarTimers, v
    ElvUI, v10.82
    ElvUIBenikUI, v3.471
    ElvUISLE, v3.46
    Enchantrix, v8.0.6158 (SwimmingSeadragon)
    Grail, v097
    GrailQuestsenUS, v27178
    MogIt, v3.8.11
    MogItArtifact, v3.8.11
    MogItOneHanded, v3.8.11
    MogItOther, v3.8.11
    MogItPlate, v3.8.11
    MogItRanged, v3.8.11
    MogItTwoHanded, v3.8.11
    MoveAnything, v17.0.0
    OPie, vVanilla 7
    Pawn, v2.2.28
    Recount, vv8.0.1c
    SellJunk, v3.0.16
    SlideBar, v8.0.6160 (SwimmingSeadragon)
    Storyline, v3.0.2
    Stubby, v8.0.6161 (SwimmingSeadragon)
    TellMeWhen, v8.5.4
    WeakAuras, v2.7.10
    XLoot, v8.0-6
    XLootFrame, v8.0-6
    XLootGroup, v8.0-6
    XLootMaster, v8.0-6
    XLootMonitor, v8.0-6
    BlizRuntimeLib_enUS v8.0.1.80000 <none>
    (ck=a65)

     

  • ray_smith posted a comment Sep 25, 2018

    I got the same error when killing a world boss when the bonus roll was happening, it appeared to prevent the "available loot" window from fully drawing or populating.

     

  • Abraxis_Endrane posted a comment Sep 26, 2018

    I have tried multiple versions available (on the Twitch launcher as well as direct download from this site) and NONE of them resolve this issue. And still am unable to find any resolution to this problem. It makes AtlasLoot pretty useless at the moment. 


    Edited Sep 26, 2018
  • arithmandar posted a comment Oct 3, 2018

    This should be fixed in 8.08.01. Please help to test it once it's released.

  • arithmandar added a tag Fixed Oct 3, 2018

To post a comment, please login or register a new account.