Bartender4-ThereIsNoCost

This project is abandoned.

Whether this project is out of date or its author marked it as abandoned, this project is no longer maintained.

If you wish to take this project over, please report it and state your intentions.

Update for 5.0.4/MoP: as far as I can tell, there are no longer any of these types of glyphs, so you shouldn't need this addon. I have uploaded a MoP version to correct breakage with abilities using the new "charges" mechanic, but barring unforeseen changes, you should be able to disable/delete this addon without noticing.


This is an adaptation of ThereIsNoCost (TINC) to work with Bartender4. TINC hides the reagent/count number on action buttons if you are using a glyph that removes the need for a reagent; however, TINC does not work with the Cataclysm implementation of Bartender4. This addon is meant as a replacement.

This addon has no configuration. It will actually work with any client code using LibActionButtons, of which Bartender4 is the {only, most popular} one at the time of this writing. You do not need to load the original TINC if you are running this addon.

There is a known issue with glyphs after the 4.0.3 patch: when initially logging in, buttons are created before glyphs have taken effect, so as far as addons can tell the reagents are still required. Zoning, /reload, scrolling the action bars, etc, will all cause the buttons to refresh themselves properly.

All credit for the original idea and implementation of TINC goes to L'ombra. My thanks to him for such a useful addon! If you find bugs in this addon, they are mine not his; please report them at this addon's page at wowace.

You must login to post a comment. Don't have an account? Register to get one!

  • 2 comments
  • Avatar of Farmbuyer Farmbuyer Nov 23, 2010 at 22:02 UTC - 0 likes

    @Sandman53: I've not been able to reproduce that. Are you using the new portal/teleport flyout buttons, or do you have specific city portals on your bars directly?

  • Avatar of Sandman53 Sandman53 Nov 11, 2010 at 09:59 UTC - 0 likes

    Im having a problem where when loading my game for the first time on my mage the cost for portals and teleports is gone. I have to fix this by doing a /reloadui and then everything works fine.

  • 2 comments

Facts

Date created
Oct 27, 2010
Categories
Last update
Aug 29, 2012
Development stage
Abandoned
Language
  • enUS
License
MIT License
Downloads
157,621
Recent files
  • R: v6 for 5.0.4 Aug 29, 2012
  • R: v5 for 4.3 Nov 30, 2011
  • R: v4 for 4.2 Jun 28, 2011
  • A: r9 for 4.2 Jun 28, 2011
  • R: v3 for 4.1 Apr 26, 2011

Authors