Ackis Recipe List

1407 - Still no Ackis Window

ARL Version (ie: 1.0):

12/19/11
ARL Revision:
2.2.0

Are you running Skillet/ATSW or any other tradeskill mods?
Mr Trader

What is the in-game error you received (DON'T INCLUDE A LIST OF ADDONS YOU ARE RUNNING, PLEASE)?

FROM BUGSACK:

2x AckisRecipeList-2.2.11\Interface\List.lua:801 bad argument #1 to 'pairs' (table expected, got nil)
AckisRecipeList-2.2.11\Interface\List.lua:801 in function `Initialize'
AckisRecipeList-2.2.11\Interface\List.lua:934 in function `Update'
AckisRecipeList-2.2.11\Interface\Panel.lua:195 in function `Display'
AckisRecipeList-2.2.11\Core.lua:1058 in function `Scan'
AckisRecipeList-2.2.11\Core.lua:658 in function <AckisRecipeList\Core.lua:636
Locals:
self = <unnamed> {
 0 = <userdata>
 ClearLines = <function> @ AckisRecipeList\Interface\List.lua:905
 entry_buttons = <table> {}
 entries = <table> {}
 ExpandEntry = <function> @ AckisRecipeList\Interface\List.lua:1386
 state_buttons = <table> {}
 Initialize = <function> @ AckisRecipeList\Interface\List.lua:781
 InsertEntry = <function> @ AckisRecipeList\Interface\List.lua:433
 Update = <function> @ AckisRecipeList\Interface\List.lua:932
 button_containers = <table> {}
 scroll_bar = <unnamed> {}
}
expand_mode = nil
general_filters = <table> {
 retired = false
 faction = true
 known = false
 unknown = true
 skill = true
 specialty = false
}
recipes_total = 0
recipes_known = 0
recipes_total_filtered = 0
recipes_known_filtered = 0
profession_recipes = nil
can_display = nil
ReleaseTable = <function> @ AckisRecipeList\Interface\Common.lua:31
table = <table> {
 setn = <function> defined =[C]:-1
 insert = <function> defined =[C]:-1
 getn = <function> defined =[C]:-1
 foreachi = <function> defined =[C]:-1
 maxn = <function> defined =[C]:-1
 foreach = <function> defined =[C]:-1
 concat = <function> defined =[C]:-1
 deepcopy = <function> @ MapNotes\MapNotesUtilities.lua:1131
 removemulti = <function> defined =[C]:-1
 sort = <function> defined =[C]:-1
 wipe = <function> defined =[C]:-1
 remove = <function> defined =[C]:-1
}
addon = <table> {
 SetDefaultModuleLibraries = <function> @ AckisRecipeList\libs\AceAddon-3.0\AceAddon-3.0.lua:383
 DisplayTextDump = <function> @ AckisRecipeList\Core.lua:1122
 EnableModule = <function> @ AckisRecipeList\libs\AceAddon-3.0\AceAddon-3.0.lua:348
RegisterModuleOptions = <function> @ AckisRecipeList\Config.lua:861
 baseName = "AckisRecipeList"
 IterateEmbeds = <function> @ AckisRecipeList\libs\AceAddon-3.0\AceAddon-3.0.lua:458
 DumpRecipe = <function> @ AckisRecipeList\Scanner.lua:572
 MERCHANT_SHOW = <function> @ AckisRecipeList\Core.lua:581
 TRADE_SKILL_UPDATE = <function> @ AckisRecipeList\Core.lua:736
 ScanTrainerData = <function> @ AckisRecipeList\Scanner.lua:114
 Printf = <function> @ AckisRecipeList\libs\AceConsole-3.0\AceConsole-3.0.lua:69
 SetDefaultModulePrototype = <function> @ AckisRecipeList\libs\AceAddon-3.0\AceAddon-3.0.lua:425
 IsEnabled = <function> @ AckisRecipeList\libs\AceAddon-3.0\AceAddon-3.0.lua:467
 Frame = ARL_MainPanel {}
 DisableModule = <function> @ AckisRecipeList\libs\AceAddon-3.0\AceAddon-3.0.lua:366
 AddRecipe = <function> @ AckisRecipeList\Recipe.lua:54
 InitRuneforging = <function> @
 scan_button = <unnamed> {}
 RegisterMessage = <function> @ AckisRecipeList\libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:118
 UnregisterMessage = <function> @ AckisRecipeList\libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:181
 GetTextDump = <function> @ AckisRecipeList\Core.lua:1254
 TooltipScanRecipe = <function> @ AckisRecipeList\Scanner.lua:977
 InitAlchemy = <function> @ AckisRecipeList\Database\Recipes\Alchemy.lua:44
 db = <table> {}
 SetEnabledState = <function> @ AckisRecipeList\libs\AceAddon-3.0\AceAddon-3.0.lua:440
 GenerateLinks = <function> @ AckisRecipeList\Scanner.lua:348
 enabledState = true
 RegisterEvent = <function> @ AckisRecipeList\libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:118
 IterateModules = <function> defined @AckisRecipeList\libs\AceAddon-3.0\AceAddon-3.0.lua
  ---

What did you do with ARL to cause the error/problem?

When opening tradeskill window for the first time there is NO scan button at all.  Closing and reopening creates a scan button, however pressing it DOES NOT SUMMON the ackis window. Resetting window position does nothing.  

Are you running with libraries embedded or disembeded?

no
How critical is fixing this defect?

very

Please provide any additional information below:

User When Change
pompachomp Dec 29, 2011 at 02:33 UTC
marblex Dec 28, 2011 at 21:04 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

Facts

Last updated
Dec 29, 2011
Reported
Dec 28, 2011
Status
Duplicate - This report duplicates an existing ticket.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees