AddonLoader

15 - New X-LoadOn-Zone problems in 4.0.1

What steps will reproduce the problem?

1. Enable AddonLoader & the following two mods: Vamp & VampArrow

2. Log on

What is the expected output? What do you see instead?

Expected: those two mods not to load until one of their AddonLoader conditionals are met. In Vamp's case:

## X-LoadOn-Slash: /vamp
## X-LoadOn-Zone: The Sanctum of Blood
## X-LoadOn-InterfaceOptions: Vamp

In VampArrow's case:

## X-LoadOn-Slash: /vamparrow
## X-LoadOn-Zone: The Sanctum of Blood

Instead: they always load "delayed" after logon. Despite none of those conditionals being met.

What version of the product are you using?

r113-release

Do you have an error log of what happened?

No errors.

Please provide any additional information below.

Those mods always loaded properly in WoW 3.x when reaching The Sanctum of Blood ICC zone. When I removed

## X-LoadOn-Zone: The Sanctum of Blood

from both of their TOCs currently, no further problems. They now paid attention to their remaining conditionals on further logons and did not load delayed. So it appears X-LoadOn-Zone: has issues in WoW 4.0.1.

User When Change
Zidomo Nov 03, 2010 at 05:39 UTC Changed description:
  What steps will reproduce the problem?

- 1. Enable AddonLoader the following two mods: [[http://www.wowace.com/addons/vamp/|Vamp]] & [[http://www.wowace.com/addons/vamparrow/|VampArrow]]
+ 1. Enable AddonLoader & the following two mods: [[http://www.wowace.com/addons/vamp/|Vamp]] & [[http://www.wowace.com/addons/vamparrow/|VampArrow]]
  2. Log on
Zidomo Nov 02, 2010 at 13:39 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 4 comments
  • Avatar of oscarucb oscarucb Feb 01, 2012 at 03:09 UTC - 0 likes

    Well it works fine now, at least under enUS (I cannot attest for the accuracy of LIbBabble-Zone). This UI has the advantage of being more readable, and thus more feasible for a user to override. I can't imagine any but the most enthusiastic user looking up mapids.

  • Avatar of mikk mikk Feb 01, 2012 at 01:40 UTC - 0 likes

    This whole mechanism is crap tbh. Should be changed to use map IDs.

  • Avatar of oscarucb oscarucb Jan 14, 2012 at 20:39 UTC - 0 likes

    Fixed in r120: The problem was GetRealZoneText() can sometimes return nil during login, and that was matching LibBabble-Zone-3.0[zone] which is usually nil on enUS.

  • Avatar of oscarucb oscarucb Jan 14, 2012 at 18:36 UTC - 0 likes

    This is happening with other addons as well eg:

    EnsidiaFailsWotlk YorsahjAnnounce

  • 4 comments

Facts

Last updated
Mar 30, 2012
Reported
Nov 02, 2010
Status
New - Issue has not had initial review yet.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
1

Reported by

Possible assignees