Error while caging battle pet. #64


  • New
  • Defect
Open
Assigned to xuerian
  • _ForgeUser1193852 created this issue Dec 6, 2012

    What steps will reproduce the problem?
    1.Cage a battle pet
    2.
    3.

    What is the expected output? What do you see instead?

    What version of the product are you using?
    XLoot-z4-alpha-27-gcdbee9a

    Do you have an error log of what happened? yes:
    1x XLoot-z4-alpha-27-gcdbee9a\Modules\Monitor\Monitor.lua:83: attempt to compare nil with number
    XLoot-z4-alpha-27-gcdbee9a\Modules\Monitor\Monitor.lua:83: in function "func"
    Monitor\Libs\LibLootEvents\LibLootEvents.lua:44: in function <Monitor\Libs\LibLootEvents\LibLootEvents.lua:42>
    Monitor\Libs\LibLootEvents\LibLootEvents.lua:218: in function <Monitor\Libs\LibLootEvents\LibLootEvents.lua:217>
    Monitor\Libs\LibLootEvents\LibLootEvents.lua:229: in function <Monitor\Libs\LibLootEvents\LibLootEvents.lua:229>
    (tail call): ?
    Monitor\Libs\LibLootEvents\LibLootEvents.lua:186: in function <Monitor\Libs\LibLootEvents\LibLootEvents.lua:186>

    Locals:
    event = "item"
    (for generator) = <func> =[C]:-1
    (for state) = <table> {
    1 = <func> @XLoot\Modules\..\Monitor.lua:79
    }
    (for control) = 1
    _ = 1
    func = <func> @XLoot\Modules\..\Monitor.lua:79
    lootcb = <table> {
    1 = <func> @XLoot\Modules\..\Monitor.lua:79
    }
    current_pattern = "You receive item: %s."

    Please provide any additional information below.

    I had 3 of the pet, and got another one from doing the fishing daily.  Not sure if the error would happen if I didn't have the same exact pet in my inventory.

  • _ForgeUser1193852 added the tags New Defect Dec 6, 2012
  • _ForgeUser1193852 posted a comment Dec 6, 2012

    Also forgot to add, all items that you pick up are being marked as bop. Overall the addon is pretty solid for an alpha. So far it's been good enough for me to have made the transition to it. Will you be releasing it as one single file or as is with different modules. I loaded them inside the modules folder, changed names, added xml to toc and it works just fine.

  • Xuerian posted a comment Dec 6, 2012

    @lurker2: Go

    With the latest version, stuff is showing BoP? Hm. I thought the line got bumped down with the ilvl line. I'll check on it. Thanks.

    As far as modules, it packages as one zip with multiple folders. You can just move them back into the modules folder and change the names and you should be set if you want to load them as a single addon.

  • _ForgeUser1193852 posted a comment Dec 8, 2012

    Not sure if this will help you track down what's causing the bop on any item, it worked just fine until I did a dungeon run and won an item. From then on anything I picked up read as being bop.


To post a comment, please login or register a new account.