Unit frames being placed incorrectly when UI is being scaled #1866

  • RevolutionNin3 created this issue Nov 20, 2022

    I am using SUF with another addon called UIScale and I'm running into an issue. UIScale is setting my interface scale to .53. When I log in to WoW, my SUF unit frames are all misaligned. However, if I open SUF config and unlock/lock frames, they all get re-aligned correctly.


    I believe the issue is related to the order the addons are loaded. Not really sure where to start with this, so I figured I'd ask here to see if anyone else has ran into something similar. 

  • UnhaltedGB posted a comment Nov 23, 2022

    You can add:


    SetCVar('useuiscale', 1)
    SetCVar('uiscale', 1)
    local _, height = GetPhysicalScreenSize()
    UIParent:SetScale(768 / height)


    To the end of the ShadowedUnitFrames.lua, under "if (event == "PLAYER_LOGIN") then". This is located around Line 1001.

    Do not replace any of the code, merely go to the end of that line, press Enter, paste the above, save and reload.


    This is not the ideal solution, but it does work.


    Should look something similar to this when you're done: https://i.imgur.com/e2TyKUB.png


    Edited Nov 23, 2022
  • SamsClan posted a comment Dec 8, 2022

    First. Thank you for this advice, it works!


    I tried the above fix and it worked, with some changes to the 'SetScale". I am playing on a 27" monitor, 2560x1440, scale is .55


    I had to update my value to '700' for it to work properly. 


    SetCVar('useuiscale', 1)
    SetCVar('uiscale', 1)
    local _, height = GetPhysicalScreenSize()
    UIParent:SetScale(700 / height)



To post a comment, please login or register a new account.