Strange Characters in Key Bindings #1030


  • Other
  • Waiting
Open
Assigned to _ForgeUser57836
  • EnigmaniteZ created this issue Jul 25, 2016

    What steps will reproduce the problem?
    1. install and activate said versions of recount and moveanything
    2. check keybindings.

    What is the expected output? What do you see instead?
    See screenshot.

    What version of the product are you using?
    7.03B Recount release from curse.
    16.0.3 MoveAnything

    Do you have an error log of what happened?
    No

    Please provide any additional information below.
    seems to be an addon conflict, but I don't know enough to be able to solve it.

  • EnigmaniteZ added the tags New Other Jul 25, 2016
  • EnigmaniteZ added an attachment WoWScrnShot_072516_144306.jpg Jul 25, 2016

    WoWScrnShot_072516_144306.jpg

  • Resike posted a comment Jul 26, 2016

    I think this is an issue on Blizzard's side.

  • EnigmaniteZ posted a comment Jul 27, 2016

    @Resike: Go

    Well, whether it is or not, I want to try to track it down to be sure. If I knew where to start, I could start poking around both addons. Where does recount register addon keybindings at? EDIT: Found the fix. added header="RECOUNT" to the bindings missing it. Seems blizz changed the way addon-defined keybindings are handled. EDIT2: Or not. It was fixed, then it wasn't. I feel noob now. I really need to learn how this stuff works >.< EDIT3 (Yes, I'm stubborn and won't give up on this): I'm poking around. I'm curious of how this works. One thing I noticed about this, is that maybe there might be a limit to keybinding container size. I moved moveanything's keybindings to the 'other' tab by removing the category tag. this reliably fixed it, as in it stuck between reloads. I'm gonna try moving recount to its own keybindings tab, same with moveanything. if that sticks...all the better.


    Edited Jul 27, 2016
  • _ForgeUser2955677 posted a comment Aug 2, 2016

    I would just like to say thanks to EnigmaniteZ for posting that work around. Opening the Bindings.xml file and removing all of the category tags has removed the gibberish from my keybinds menu. This also works for any other addon that is causing this problem (moveanything and tomtomping for me). Thanks!

  • _ForgeUser5456993 posted a comment Aug 3, 2016

    I can also confirm that removing the category tags fixes the keybindings menu problems. The only downside is that everything now ends up in the "Other" section down at the bottom. =\

  • Resike posted a comment Aug 5, 2016

    This is really weird, because it's seems like it's only happening for the addons that i'm maintaining. Maybe it's an encoding issue then?

  • EnigmaniteZ posted a comment Aug 5, 2016

    @Resike: Go

    I poke and I poke and I poke. So much code poking, trying to figure out where the problem lies. And...the only thing that has any constancy to it, is removing the category tags removes the problem and shifts recount's keybinds into Other I commented out localization, tried changing the category tag names, etc.

    and...I just found something that's persisted through 10 reloads. I added to each binding description="test" Another edit! just to clarify, I only applied this to 'fix' to recount. turned on all addons, kept reloading, significantly fewer 'broken' entries now. I applied the same 'fix' to other addons, but it ended up just breaking things again. still, at least it gives some kind of direction. Edit (4pm!): So...more poking done. checked over addons with binding xml files that I have installed. totalrp has no description headers, but causes no issue. same with addonusage, savedinstances, wim, minimap button frame, mogit, moveanything, paste, rematch. However, petemotes kept causing the issue. when I moved the header to after the category, however, this reduced the incidence rate significantly, from 90% of the time to like 5% of the time. I wonder why order matters so much... EDIT: references from my musings.


    Edited Aug 5, 2016
  • Resike posted a comment Aug 9, 2016

    @EnigmaniteZ: Go

    I think the main issue is that if you add too much entries into one category table, then the table gets overflow and can't proeprly load their values, which causes the issue. I guess we will have to wait for a Blizzard fix, or move stuff into other categories.


    Edited Aug 9, 2016
  • EnigmaniteZ posted a comment Aug 10, 2016

    @Resike: Go

    close to what I'm seeing the issue as, but not quite. it's not an issue with the number of entries in the category table. Keep in mind that I had the table loaded down with a ton of entries, and by reordering tags alone I reduced the occurrence rate of the issue. to get an idea of what's happening, as far as I can see, try looking at it like this: while reading the xml, each line is stored in a buffer, each piece of it is processed sequentially. the issue seems to occur because the buffer is spilling off into nearby memory space. as noted in the second link I added in a post, it seems to be related to the binding name being too long, which supports my theory. pretending a buffer size of 16 bytes, filling it with 12 leaves 4 over, then it tries sticking 8 more in there, overflowing by another 4. Then all hell breaks loose. My ingame testing seems to confirm that this is what is happening. long story short: buffer too small or being handled improperly. Slap blizz. Blizz does not pass go, does not collect 200 dollars. Fix by reducing size of binding names to something ridiculously short, or by screaming at blizzard. All I can think of, really...

  • _ForgeUser6401858 posted a comment Sep 10, 2016

    I can confirm that I am also experiencing the reported Weird Character issue in the "Keybindings" section of my game menu. Please see here: http:prntscr.com/cglfb1

    I do not use MoveAnything, and the screenshot above was taken without MoveAnything on my computer. However, Recount was indeed installed when MoveAnything was present in my Addons folder.

    Additionally, any changes I make to my key bindings do not save correctly, and are lost each time I logout. I have to save key bindings with Recount disabled for them to persist between reboots.

    I love recount and hope this is fixed in an upcoming release!

    Thanks,

  • Resike posted a comment Sep 20, 2016

    7.1 will fix this. (If we can trust in Blizzard.)


    Edited Sep 20, 2016
  • Resike removed a tag New Sep 20, 2016
  • Resike added a tag Waiting Sep 20, 2016

To post a comment, please login or register a new account.