Ratingbuster Error #303


  • New
  • Defect
Open
Assigned to _ForgeUser31
  • _ForgeUser4038354 created this issue Feb 7, 2014

    Ratingbuster doesn't seem to be working for me at the moment, I keep getting the following error:-

    Date: 2014-02-07 10:43:44
    ID: 1
    Error occured in: Global
    Count: 1
    Message: ...ingBuster\libs\LibStatLogic-1.2\LibStatLogic-1.2.lua line 6524:
       attempt to call global 'GetPrimaryTalentTree' (a nil value)
    Debug:
       ...ingBuster\libs\LibStatLogic-1.2\LibStatLogic-1.2.lua:6524:
          ...ingBuster\libs\LibStatLogic-1.2\LibStatLogic-1.2.lua:6516
       ...ingBuster\libs\LibStatLogic-1.2\LibStatLogic-1.2.lua:6530:
          ...ingBuster\libs\LibStatLogic-1.2\LibStatLogic-1.2.lua:6527
    Locals:
    (*temporary) = nil
    (*temporary) = "attempt to call global 'GetPrimaryTalentTree' (a nil value)"
    ArmorSpecActive = nil
    pairs = <function> defined =[C]:-1
    WatchInventoryID = <table> {
    1 = 1
    2 = 3
    3 = 5
    4 = 9
    5 = 10
    6 = 6
    7 = 7
    8 = 8
    }
    GetInventoryItemID = <function> defined =[C]:-1
    select = <function> defined =[C]:-1
    GetItemInfo = <function> defined @Interface\AddOns\RatingBuster\libs\LibStatLogic-1.2\LibStatLogic-1.2.lua:5874
    playerArmorType = "Mail"

    AddOns:
      Swatter, v4.4.0 (<%codename%>)
      AtlasLootLoader, vv7.07.01
      aTotemBar, v
      Babylonian, v5.1.DEV.332(/embedded)
      BagBrother, v
      Bagnon, v5.4.9
      BagnonFacade, v9
      BagnonScrap, v
      BigLibTimer, v6.0.5
      BittensSpellFlashLibrary, v50400.4.1
      ButtonFacade, v5.4.396
      Carbonite, v5.4.0 alpha 2
      CarboniteInfo, v1.0
      CarboniteNodes, v1.02
      CarboniteNotes, v1.1
      CarboniteNotesSample, v1.0
      CarboniteQuests, v1.0
      CarboniteSocial, v1.0
      CarboniteTransfer, v1.01
      CarboniteWarehouse, v1.0
      CarboniteWeekly, v1.0
      CarboniteTransfer, v1.01
      Configator, v5.1.DEV.344(/embedded)
      DBMCore, v
      DBMStatusBarTimers, v
      Dominos, v5.4.8
      DominosCast, v
      DominosEncounter, v
      DominosRoll, v
      DominosXP, v
      Gatherer, v4.4.0
      GearScore, v5.2.0
      GTFO, v4.27.2
      LibSharedMedia30, v3.0-86
      Masque, v5.4.396
      Omen, v3.1.8
      Prat30, v3.5.7
      Prat30Libraries, v
      pusikasspellflashttd, v1.1
      RatingBuster, v1.6.7
      Recount, v
      Scrap, v12.11
      sct, v6.65
      sctd, v6.65
      ShadowedUnitFrames, vv3.10.3
      SlideBar, v4.4.0 (<%codename%>)
      SpellFlash, v6.10
      SpellFlashCore, v2.0.4
      TidyPlates, v6.13.4
      TidyPlatesGraphite, v
      TidyPlatesGrey, v
      TidyPlatesNeon, v
      TidyPlatesQuatre, v
      TidyPlatesHub, v
      TidyPlatesWidgets, v
      tullaRange, v5.4.0
      BlizRuntimeLib_enUS v5.4.2.50400 <eu>
      (ck=517)

    This happens when I hover over an item in my bag.  Is there anyway to fix this?  I have tried uninstalling and reinstalling the addon which has no effect.  Please help, the version I am using is 1.6.7.  Thank you.

  • _ForgeUser4038354 added the tags New Defect Feb 7, 2014
  • mcremor posted a comment Feb 7, 2014

    Your version of RatingBuster is ancient. Download the latest Alpha version of RatingBuster from here: http://www.wowace.com/addons/rating-buster/files/


To post a comment, please login or register a new account.