LUA error on release 7.1.0.2 #160


  • Fixed
Closed
  • _ForgeUser93069 created this issue Nov 20, 2016

    Received following error in Swatter on login after new update to 7.1.0.2

    Date: 2016-11-20 11:17:02
    ID: 1
    Error occured in: Global
    Count: 1
    Message: ..\AddOns\NPCScan\Core.lua line 17:
    Usage: EmbedLibrary(addon, libname, silent, offset): 'libname' - Cannot find a library instance of "LibSink-2.0".
    Debug:
    [C]: ?
    ...\AddOns\DataStore\libs\AceAddon-3.0\AceAddon-3.0.lua:220: EmbedLibrary()
    ...\AddOns\DataStore\libs\AceAddon-3.0\AceAddon-3.0.lua:202: EmbedLibraries()
    ...\AddOns\DataStore\libs\AceAddon-3.0\AceAddon-3.0.lua:169: NewAddon()
    NPCScan\Core.lua:17: in main chunk
    Locals:
    (*temporary) = "Usage: EmbedLibrary(addon, libname, silent, offset): 'libname' - Cannot find a library instance of "LibSink-2.0"."

    [rest of error message truncated as irrelevant]

     

  • _ForgeUser93069 added a tag New Nov 20, 2016
  • _ForgeUser737942 posted a comment Nov 20, 2016

    Also getting this issue. NPCScan will not alert when in proximity to rares nor will the Star for the rare's actual real-time location show up in the minimap.

    Running NPCScan ver 7.1.0.2-nolib

    Tried uninstalling and reinstalling.

     

    Date: 2016-11-20 20:48:16
    ID: 1
    Error occured in: Global
    Count: 1
    Message: ..\AddOns\NPCScan\Core.lua line 17:
       Usage: EmbedLibrary(addon, libname, silent, offset): 'libname' - Cannot find a library instance of "LibSink-2.0".
    Debug:
       [C]: ?
       ...AddOns\AskMrRobot\Libs\AceAddon-3.0\AceAddon-3.0.lua:220: EmbedLibrary()
       ...AddOns\AskMrRobot\Libs\AceAddon-3.0\AceAddon-3.0.lua:202: EmbedLibraries()
       ...AddOns\AskMrRobot\Libs\AceAddon-3.0\AceAddon-3.0.lua:169: NewAddon()
       NPCScan\Core.lua:17: in main chunk
    Locals:
    (*temporary) = "Usage: EmbedLibrary(addon, libname, silent, offset): 'libname' - Cannot find a library instance of "LibSink-2.0"."

    AddOns:
      Swatter, v7.2.5688 (TasmanianThylacine)
      AskMrRobot, v48
      AucAdvanced, v7.2.5688 (TasmanianThylacine)
      AucFilterBasic, v7.2.5688 (TasmanianThylacine)
      AucFilterOutlier, v7.2.5688.5459(7.2/embedded)
      AucMatchUndercut, v7.2.5688.5585(7.2/embedded)
      AucStatHistogram, v7.2.5688 (TasmanianThylacine)
      AucStatiLevel, v7.2.5688 (TasmanianThylacine)
      AucStatPurchased, v7.2.5688 (TasmanianThylacine)
      AucStatSales, v7.2.5688.5598(7.2/embedded)
      AucStatSimple, v7.2.5688 (TasmanianThylacine)
      AucStatStdDev, v7.2.5688 (TasmanianThylacine)
      AucStatWOWEcon, v7.2.5688.5613(7.2/embedded)
      AucUtilAHWindowControl, v7.2.5688.5575(7.2/embedded)
      AucUtilAppraiser, v7.2.5688.5666(7.2/embedded)
      AucUtilAskPrice, v7.2.5688.5599(7.2/embedded)
      AucUtilAutoMagic, v7.2.5688.5686(7.2/embedded)
      AucUtilCompactUI, v7.2.5688.5629(7.2/embedded)
      AucUtilEasyBuyout, v7.2.5688.5576(7.2/embedded)
      AucUtilFixAH, v7.2.5688 (TasmanianThylacine)
      AucUtilItemSuggest, v7.2.5688.5651(7.2/embedded)
      AucUtilPriceLevel, v7.2.5688.5633(7.2/embedded)
      AucUtilScanButton, v7.2.5688.5631(7.2/embedded)
      AucUtilScanFinish, v7.2.5688.5588(7.2/embedded)
      AucUtilScanProgress, v7.2.5688.4979(7.2/embedded)
      AucUtilScanStart, v7.2.5688.5347(7.2/embedded)
      AucUtilSearchUI, v7.2.5688.5672(7.2/embedded)
      AucUtilSimpleAuction, v7.2.5688.5654(7.2/embedded)
      AucUtilVendMarkup, v7.2.5688.4828(7.2/embedded)
      Babylonian, v5.1.DEV.332(/embedded)
      BagBrother, v
      Bagnon, v7.1.1
      Bartender4, v4.7.4
      BeanCounter, v7.2.5688 (TasmanianThylacine)
      Configator, v5.1.DEV.406(/embedded)
      DBMCore, v
      DBMDefaultSkin, v
      DBMStatusBarTimers, v
      DebugLib, v5.1.DEV.337(/embedded)
      HandyNotes, vv1.4.11
      HandyNotesLegionRaresTreasures, v1.01b
      LibExtraTip, v5.12.DEV.416(/embedded)
      MyRolePlay, v7.1.0.405
      NPCScan, v7.1.0.2
      Stubby, v7.2.5688 (TasmanianThylacine)
      TipHelper, v5.12.DEV.405(/embedded)
      BlizRuntimeLib_enUS v7.1.0.70100 <none>
      (ck=78a)


    Edited Nov 20, 2016
  • _ForgeUser93069 posted a comment Nov 21, 2016

    I just noticed the coincidence that the version has "nolib" in it and the error is about a missing library. Interesting. 


    Edited Nov 21, 2016
  • The4thDoctor posted a comment Nov 23, 2016

    There is a bug in the LIbSink-2.0.xml the xml schema has a reference to a local file system path  

     

    <Ui xmlns="http://www.blizzard.com/wow/ui/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.blizzard.com/wow/ui/
    C:\Projects\WoW\Bin\Interface\FrameXML\UI.xsd">

    <script file="LibSink-2.0.lua"/>

    </Ui>

     

    just change the xml for LibSink-2.0.lua to this

     

    <Ui xmlns="http://www.blizzard.com/wow/ui/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.blizzard.com/wow/ui/
    ..\FrameXML\UI.xsd">

    <script file="LibSink-2.0.lua"/>

    </Ui>


    Edited Nov 23, 2016
  • _ForgeUser93069 posted a comment Nov 24, 2016

    Steampunkhawk, thanks for finding that oversight.  
    I spent a good while looking for LibSink-2.0.lua or LibSink-2.0.XML and other such files anywhere in the WoW folders with no luck. You didn't happen to provide the path. Eventually I realized that I had 7.1.0.1-NOLIB. <<--- Hint!

    I grabbed 7.1.0.2, which has the Libs folder, and the rest of the files are there now.
    I edited ~\AddOns\NPCScan\Libs\LibSink-2.0\lib.xml as you demonstrated and I no longer get the LUA error on game launch. 
    But wait, this gets MUCH BETTER. 
    For the last couple of weeks or so my game loading screen times have been AWFUL. Like, initial game load it could take 90 seconds to get into the world. Then, each load of an instance, like taking a portal to another city, especially the Garrisons for some reason, could take 30 seconds. And my PC is not THAT outdated. :) 
    Well, as of just now, it's FAST. Initial load ~10 second, port to Garrison, less. 
    So, this one simple fix to this file has completely fixed my entire gaming experience. 
    THANK YOU! 

    This simple fix to the XML needs to get patched and released pronto. :) 



    Edited Nov 24, 2016
  • Torhal added a tag Fixed Dec 9, 2016
  • Torhal removed a tag New Dec 9, 2016
  • Torhal closed issue Dec 9, 2016

To post a comment, please login or register a new account.