:SetLineTextColor broken with spanned columns #39


  • New
  • Defect
Open
Assigned to torhal
  • xemnosyst created this issue Jul 27, 2013

    What steps will reproduce the problem?
            local row = tooltip:AddLine()
            tooltip:SetCell(row, 1, label, nil, nil, 3)
            tooltip:SetCell(row, 4, hint)
            tooltip:SetLineTextColor(
                row, NORMAL_FONT_COLOR.r, NORMAL_FONT_COLOR.g, NORMAL_FONT_COLOR.b)

    What is the expected output? What do you see instead?
    Message: Interface\AddOns\LibQTip-1.0\LibQTip-1.0.lua:1097: attempt to index field '?' (a boolean value)
    Time: 07/27/13 09:54:13
    Count: 1
    Stack: [C]: ?
    Interface\AddOns\LibQTip-1.0\LibQTip-1.0.lua:1097: in function `SetLineTextColor'
    Interface\AddOns\KnowYourLootSpec\src\Tooltip.lua:38: in function <Interface\AddOns\KnowYourLootSpec\src\Tooltip.lua:33>
    Interface\AddOns\KnowYourLootSpec\src\Tooltip.lua:62: in function `RefreshTooltip'
    Interface\AddOns\KnowYourLootSpec\src\Tooltip.lua:28: in function `ShowTooltip'
    Interface\AddOns\KnowYourLootSpec\src\DataBroker.lua:13: in function `OnEnter'
    Interface\AddOns\Bazooka\Bazooka.lua:1431: in function `showTip'
    Interface\AddOns\Bazooka\Bazooka.lua:1246: in function <Interface\AddOns\Bazooka\Bazooka.lua:1237>

    What version of the product are you using?
    1.0, minor 42

    Do you have an error log of what happened?
    see above

    Please provide any additional information below.
    line.cells[cell_index] contains the boolean "false" for cells that are skipped because a previous cell spans over it, so the line in this loop body throws the exception:
        for cell_index = 1, #line.cells do
            self:SetCellTextColor(lineNum, line.cells[cell_index]._column, r, g, b, a)
        end

  • xemnosyst added the tags New Defect Jul 27, 2013
  • xemnosyst edited description Jul 27, 2013

To post a comment, please login or register a new account.