line 51: attempt to index field '?' (a nil value) #22


  • New
  • Defect
Open
Assigned to allinonemighty
  • pppmhagu created this issue Jul 26, 2012

    What steps will reproduce the problem?
    1. i get error immediately upon /reload
    2.
    3.

    What is the expected output? What do you see instead?

    What version of the product are you using?

    Do you have an error log of what happened?
    Date: 2012-07-26 10:51:22
    ID: 1
    Error occured in: Global
    Count: 1
    Message: ..\AddOns\Elephant\Event.lua line 51:
       attempt to index field '?' (a nil value)
    Debug:
       (tail call): ?
       [string "*:OnLoad"]:6:
          [string "*:OnLoad"]:1
       (tail call): ?
       Elephant\Event.lua:51:
          Elephant\Event.lua:25
       ...Ons\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:157:
          ...Ons\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:157
       [string "safecall Dispatcher[15]"]:4:
          [string "safecall Dispatcher[15]"]:4
       [C]: ?
       [string "safecall Dispatcher[15]"]:13: ?()
       ...Ons\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:92: Fire()
       Ace3\AceEvent-3.0\AceEvent-3.0.lua:120:
          Ace3\AceEvent-3.0\AceEvent-3.0.lua:119
    AddOns:
    ...
      Elephant, v3.1.2.1

    Please provide any additional information below.

  • pppmhagu added the tags New Defect Jul 26, 2012
  • ianayoung posted a comment Sep 10, 2012

    I am seeing this from time to time as well. In my case, it's just randomly while doing something rather than at a specific time.


    Edited Sep 10, 2012

To post a comment, please login or register a new account.