Actionbar issue #95


  • Defect
Open
  • Selthi created this issue Jun 1, 2021

    Hello, I ran into an issue where the actionbar hotkeys are disappearing and buttons aren't clickable until a reload. It' was a bit hard to force, since it seems that only one kind of vehicle is causing it. It seems to always occur at Aspirant world quest in Bastion, but only after leaving by completing it, not by using the exit button. I think it never happened after pet battles.

    Now I found out that there is a crypt in Maldraxxus where neutral spiderlings seem use the same vehicle (entrance at 24.5 31.6) when jumping on you, so I could test it. Sometimes it took two spiderlings, but mostly just one.

    That's the vehicle type, if that helps? I've tried v3.6.15, 14 and 13. Then I went back to v3.6.5 as it's the first in 9.0.5 where it doesn't seem to occur. In v3.6.6 it happened again.

  • Selthi added a tag Defect Jun 1, 2021
  • miarenn posted a comment Sep 22, 2021

    You do use a bottom bar right?

  • Selthi posted a comment Sep 22, 2021

    No, I use one permanent  top bar and the second top bar with mouseover.

  • nick_nullafy posted a comment Sep 22, 2021

    I too have this issue still with just a single top bar enabled.

     

    Looking through the closed issues it is identical to this problem as well if it helps - Closed Issue 76

  • Selthi posted a comment Sep 23, 2021

    I'm not sure if issue 76 is the same. 76 only had to do combat state, this wasn't always the case for me, see the named WQ in Bastion.

    I got an error with v3.6.5 which was combat related. It did not occur with a later version, where I found this, so I added this in v3.6.5's Jostle.lua, line 408 and everything seems fine :).

      

    if not InCombatLockdown() then
    frame:ClearAllPoints()
    frame:SetPoint(anchor, anchorFrame, anchorAlt or anchor, x, y + offset)
    blizzardFramesData[frame].lastX = frame:GetLeft()
    blizzardFramesData[frame].lastY = frame:GetTop()
    blizzardFramesData[frame].lastScale = framescale
    end

     


    Edited Sep 23, 2021
  • nick_nullafy posted a comment Sep 24, 2021

    The I am having occurs every time entering a vehicle regardless if you are in combat or not - also happened with the ember court atonement ritual judging for example. I don't believe I have seen it with pet battles.

     

    The recent version's appear to have those lines present and I am still experiencing the issue - hopefully it may all be related.


To post a comment, please login or register a new account.