SetBackdrop change in 9.x (Shadowlands) #84


Closed
  • spiralofhope posted a comment Oct 14, 2020

    OBSOLETE - see the top comment

     

     

     Change line 30 to

    local frame = CreateFrame("Frame",name,UIParent, BackdropTemplateMixin and "BackdropTemplate")

     


    Edited Oct 16, 2020
  • Gheldean posted a comment Oct 14, 2020

    This would be in Bar.lua (specifying since there are multiple .lua files)


    Edited Oct 14, 2020
  • Clexea posted a comment Oct 14, 2020

    The Bar.lua fix worked for displaying the bars, thank you!  One thing I did notice is interaction with Broker Everything seems to be broken even with the bars visible.  Either the mouseover dropdowns aren't working or (in some cases), clicking through has no effect at all.

  • kamisengames posted a comment Oct 14, 2020

    This fix has to be applied to every part of the addon that creates a frame, that includes tooltips and dropdown menus

     

  • All_Caulle posted a comment Oct 14, 2020

    I'm running into the same issue with the mouseover tooltips.  Only the Bar.Lua file had any reference to CreateFrame that I could find so having trouble figuring out where to apply the fix for mouseover tooltips.  But that Bar.Lua fix worked.

  • spiralofhope posted a comment Oct 14, 2020

    I'm seeing significant efforts over here:

     

    https://github.com/the-rebel-Mermaid/ChocolateBar/pull/3/commits/763d86936f3a76c96552e1d247a681f4e2d8845c

     

    You can comment here:

     

    https://github.com/the-rebel-Mermaid/ChocolateBar/pull/3

     

    I'll leave this issue open for now, so others can find this.

  • spiralofhope edited description Oct 14, 2020
  • Clexea posted a comment Oct 14, 2020

    @spiralofhope I added in those GitHub changes.  Combined with the latest Alpha of Broker_Everything the changes seem to have fixed the broker information display.

  • Forge_User_04326382 posted a comment Oct 14, 2020

    Disregard I forgot to comit a change


    Edited Oct 14, 2020
  • All_Caulle posted a comment Oct 14, 2020

    Okay, some updates to data broker plugins fixed my mouseover issues. So for others running into issues.  Update your bar.lua file with the comments above, and then update individual addons.  If those aren't working post on their threads for bug tickets (if there isn't an update or work around).

  • Forge_User_19536481 posted a comment Oct 15, 2020

    Not sure if I understand it all with the changes suggested by everyone. Can someone make a TL:DR about what we should change for the addon to work please? Thanks in advance.

  • spiralofhope posted a comment Oct 15, 2020

    @Ithylz

     

    I think you can download this entire zip overtop of your current installation, and it will overwrite your stuff with all that person's changes.

     

  • spiralofhope edited description Oct 16, 2020
  • Forge_User_19536481 posted a comment Oct 16, 2020

    Strangely enough, it didn't do anything. The addon doesn't even appear in the addon list :(

  • spiralofhope posted a comment Oct 24, 2020

    I'm not sure how help; be certain you're not making a sub-subdirectory.

  • miarenn closed issue Mar 28, 2021
  • miarenn posted a comment Mar 28, 2021

    This should be fixed with the current version :)


To post a comment, please login or register a new account.