BFA ActionBars and Vehicles #76


  • Defect
Open
  • Frozen_Paradox created this issue Dec 11, 2018

    It seems the issue with vehicles breaking ActionBars is back.
    I've just levelled an alt 1-110 with no issues entering and exiting vehicles up until I hit BFA content,
    at which point exiting vehicles makes it impossible to interact with any ActionBars with your cursor.
    The old temp fix still works which is to /reload

  • Frozen_Paradox added a tag Defect Dec 11, 2018
  • Rorthron99 posted a comment Jul 28, 2019

    I have had the same issue for a long time. I narrowed it down the ChocolateBar. If I disable this addon, all works fine. 

     

    The bottom action bars still work with key binds, but you cannot select any of the icons on the bar. 

     

    There are no addon LUA errors reported. 

     

    Sad to see that this was reported by someone 8 months ago and it clearly is still an issue. I will have no choice but to ditch chocolatebar as I am getting stuck without the ability to use the actionbar. Forcing a reload isn't an acceptable workaround in my opnion. 

  • Rorthron99 posted a comment Aug 7, 2019

    Worked out the cause. It seems that BFA changed how the main menu bar was managed and it was causing issues when being in a vehicle AND being in combat at the same time. Just hopping on and off a vehicle without combat always worked fine. 

     

    Open up Jostle.lua and add the following two lines in bold in the following function. 

     

    function Jostle:UNIT_EXITED_VEHICLE()
    <strong>    MainMenuBar:SetMovable(true)
        MainMenuBar:SetUserPlaced(false)</strong>
    
        self:Refresh(MainMenuBar)
    end

     

    This has resolve the issue for me. 


To post a comment, please login or register a new account.