Change log

    - make it a luadoc comment
    - fix indention
    - documentation
    - put the name in a variable
    - alignment
    - use constants for color
    - documentation
    - indention
    - acedb stuff
    - not a text
    - fix indention in .pkgmeta
    - create a .pkg meta and set up the rest
    - unfortunately, there is no coauthor tag
Schnurz Egal:
    - remove this file
    - CR/LF Problem
    - clean up folder
    - Update toc
    - some handling changes
    - another bugfix
    - bugfix
    - tooltip polish
    - typo
    - New Icon
    - whitespace
    use spaces, 4 spaces per tab, use NL
    - make it a luadoc comment
    - seems better
Schnurz Egal:
    - show and hide tipframe for details of Gem
    - and back to tipframe
    - some toottip show and hide stuff
    - removed some useless stuff
    - removed some Debug stuff working tooltip for gems working collapse/expand category ToDo: Update Tooltip after collapse/expand
    - gemcount.lua:236 attempt to concatenate local 'color' (a table value) Why that?
    - vars: again id -> link acedb
    - alignment
Schnurz Egal:
    - name the frame
    - vars: id -> link
    - syntax: end if -> end
    - really. no. end if. ever.
Schnurz Egal:
    - some corrections
    - there is no end if in lua
    - no statement after return
    - that never was an id, it's always been a link also add assertion at usage
    - don't name the frame
Schnurz Egal:
    - some stylingstuff and formatting in tooltip Importand todo: build addon.db Ace3 settings
    - Some Sorting and Styling Stuff
    - som testing with the Tooltip
    - bugfix
    - Testing Gametooltip showing details of Gem
    - Release Tooltip on Leave
    - don't create frame everytime
Schnurz Egal:
    - Merge branch 'master', remote branch 'origin'
    - Cleanup
    - Persistant Tooltip funktioniert jetzt
    - docu typo
    - blizz changed this in patch 4.06
Schnurz Egal:
    - Make Init Event configurable on Top to test events
    - nil check
    - "tooltip" overrides "OnEnter"/"OnLeave" -> be gone!
    - renamed update_tooltip to fillTooltip
    - fill feels like a better wording
    - codestyle
    - remove old code
    - move tooltip to addon.tooltip
    no particular reason, just my style
    - debug stuff
Schnurz Egal:
    - Show Tooltip only once. Secound time it is empty
    - use addon.dataObject instead of self
    - show it
Schnurz Egal:
    - Leerer Tooltip
    - LibQTip Integration
    - Wiedererkennungswert
    - Variable
    - Formatting
    - localization fix
Schnurz Egal:
    - Syntax
    - fix do block
Schnurz Egal:
    - Initial Event
    - removed localization of gemcolors as this can be done ingame
    - camelcase typo
    - output
    - camel case
    - store more
    - if present, store the gem's name, else remove entry
    - combination of slotname and gem id
    - table for gem information
    - need the gem's name
    - cache gemcount
    - formatting
    - documentation upgrade
    - documentation upgrade
    - rewording
    - add a brief description
    - swap them
    in general first parameter then return
    - whitespace
    - typo, type, more details, capitalization
    - not localized
    - use addon name here
Schnurz Egal:
    - Documentation
    - Minor Design Changes
    - event für erstmaliges starten
    - documentation
    - Useless
    - Event 'UNIT_STATS' mal sehn was es bringt
    - this might simplify things... or break
    - bugfix
Schnurz Egal:
    - Fix Typo
    - rename gemcount_updateldb->updateLDB
    There is NO point at all in prefixing local functions.
    - consider it a constant
    - codestyle
    no ; at end of line
    - don't need that event
    - no point in doing something before the addon is enabled
    - alignment
    - documentation
    - consider it a constant
    - create the dataobject not onload but OnEnable dataobject is no longer local but now a member of addon
    - bug fix.
    - dont register events on load, register OnEnable
    - thats currently a local function
    - rename dataobj->dataObject
    - split dataobject creation in two parts
    - function is no longer strictly local
    - formatting
    - move dataobject creation upwards
    not sure if this is working 100% now
    - extract dataobject name to connstant
    see a pattern here?
    - extract addon name to constant
    - extract locale name to constant
    - alignment
    - move acelocale upwards, too
    - move library fetching up
    - long form is more readable
    - extract AceAddon to a local variable
    no specific reason, probably not even an improvement in speed, on the other hand executed only once anyway.
    does improve readability though
    - remove unneeded frame and event stuff
    - rename function Gemcount_Checkmeta->checkMeta
    - rename function CountGem->countGems
    - move two function to local block
    - make functions local.
    - begin structure of code
    - remove unneeded code
    - alignment
    - i think these names are pseudo constants
Schnurz Egal:
    - - Events für LDB Text verwendet (sollte evtl umgestellt werden auf None Ace Event, weil es dann alles in einer function erledigt werden kann) - Status des Meta Gem ausgewertet (passende Farbe für aktiven/inaktiven Meta muss noch verbessert werden)
    - Neue Testversion zum mergen von Chils Änderungen
    - grammar
    - alignment
    - Constants for color.
    - codestyle
    i use single quotes for strings which are basically constants and double quotes for texts
Schnurz Egal:
    - Done: - Lokalization - Typos - Order - LDB Text now shows Colorformatet Count of Gems (Updaterate 10 Secounds) Todo: - Updateevent should be changed to Events for Equipmentchange instead of Timer
    - Neuer Versuch mit lokalisierung
    - Test der Lokalisierung
    - Documentation
    - ignoring compiled file
    - debug in case of unknown gemcolor
    - debugging related
    Get a DebugLogBackend.
    - documentation
    - That should not be needed.
    - feature: add the gem information to tooltip
    - codestyle
    player is a fixed string constant
    - Documentation start.
    - documentation
    - documentation
    - codestyle
    - documentation, codestyle
    - split declaration in two
    - bugfix, move function declaration before us
    The local variable LDBclick was not defined at the point it was first used.
    - comments
    - codestyle
    - tweaks, comments
    - autoformat
    - move to top, mainly codestyle
Schnurz Egal:
    - Neue Reihenfolge
    - Funktionierender LDB DataFeed mit Leftclick zum Charframe Toggle und einer einzeiligen Tooltipzeile
    - Removed changelog, renamed libs
    Changelog has nothing to do here
    Libs should better be libs
Schnurz Egal:
    - Erster Test mit Libs und zusammenkopierten Funktionen für LDB Ausgabe und Gem Erfassung
    - Dies ist nur die Versionsbeschreibung
    - Readme


Uploaded on
Mar 09, 2011
Game version
  • 4.0.6
46.6 KiB