X-Perl UnitFrames

1579 - Runebutton

What steps will reproduce the problem?
1. Error comes up at login
2.
3.

What is the expected output? What do you see instead?
I don't know.

What version of the product are you using?
r847

Do you have an error log of what happened?
52x FrameXML\RuneFrame.lua:54 attempt to index local "self" (a nil value)
FrameXML\RuneFrame.lua:54 in function "RuneButton_Update"
XPerl_Player\XPerl_Player-r847.lua:1096 in function "?"
XPerl_Player\XPerl_Player-r847.lua:746 in function <XPerl_Player\XPerl_Player.lua:740

Locals:
self = XPerl_Player {
 classFrame = XPerl_PlayerclassFrame {}
 portraitFrame = XPerl_PlayerportraitFrame {}
 nameFrame = XPerl_PlayernameFrame {}
 dropdownMenu = PlayerFrameDropDown {}
 permenantVoiceID = true
 hitIndicator = XPerl_PlayerhitIndicator {}
 tutorialPage = 2
 BOTTOMLEFT = "TOPLEFT"
 Power = 0
 buffSpacing = <table> {}
 buffFrame = XPerl_PlayerbuffFrame {}
 FlashFrames = <table> {}
 buffOptMix = "0000210"
 feedbackFontHeight = 30
 highlight = XPerl_Playerhighlight {}
 updateAFK = true
 TOPRIGHT = "BOTTOMRIGHT"
 time = 0
 feedbackText = XPerl_PlayerhitIndicatortext {}
 SPACING = 1
 statsFrame = XPerl_PlayerstatsFrame {}
 conf = <table> {}
 TOPLEFT = "BOTTOMLEFT"
 groupFrame = XPerl_PlayergroupFrame {}
 0 = <userdata>
 BOTTOMRIGHT = "TOPRIGHT"
 voiceButton = XPerl_VoiceSpeaker {}
 debuffFrame = XPerl_PlayerdebuffFrame {}
 partyid = "player"
 EnergyLast = 0
 VSPACING = 1
 lastAbove = 1
 levelFrame = XPerl_PlayerlevelFrame {}
}
self = "RUNE_TYPE_UPDATE"
runeIndex = 1

Please provide any additional information below.
N/A

User When Change
Asixandur May 04, 2013 at 15:05 UTC
PlayerLin Apr 19, 2013 at 17:30 UTC
Mardleseyth Apr 19, 2013 at 00:51 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 2 comments
  • Avatar of PlayerLin PlayerLin Apr 19, 2013 at 17:19 UTC - 0 likes

    Please provide any additional information below.

    N/A

    Whoever posting tickets like this should leave some information like your character's class, level, race or something or else just remove that section if you don't have any additional info....

    I know it's possible DK because "runebutton" but due Blizzard's buggy coding at whole FrameXML shit so we can't sure unless reporter wrote enough information...

    Last edited Apr 19, 2013 by PlayerLin
  • Avatar of Asixandur Asixandur Apr 19, 2013 at 04:11 UTC - 0 likes

    It comes up everytime or you just seen it once? What class is your pg?

  • 2 comments

Facts

Last updated
May 04, 2013
Reported
Apr 19, 2013
Status
Invalid - This was not a valid report.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees