X-Perl UnitFrames

1531 - 1075 - Casting Monitor player targets (Still not working)

What steps will reproduce the problem?
1. Join a raid
2. Enable Casting Monitor
3. Any players/classes you choose, all of their targets are GRAYED out.  It used to work where if you were targeting the same mob, it would be green etc, now i cannot see anyones target which was quite useful

What is the expected output? What do you see instead?
to see the targets and even more the highlights of people who have the same target as you ... im wating for this for about 2,5 years now since it was broken it worked perfectly in the past

What version of the product are you using?
all versions in the past 2.5 years

Do you have an error log of what happened?
well there is no error its just blank gray

Please provide any additional information below.
Screenshot
http://www.wowace.com/media/attachments/12/421/Cast_monitor_bug.jpg

Old Closed Ticket
http://www.wowace.com/addons/xperl/tickets/1075-casting-monitor-player-targets/

  • Cast_monitor_bug.jpg
    Bug Exist for about 3 years now
User When Change
Asixandur Nov 11, 2013 at 12:44 UTC Changed status from Accepted to Waiting
Asixandur Jan 20, 2013 at 06:08 UTC
Daytac Jan 19, 2013 at 12:44 UTC

Added attachment Cast_monitor_bug.jpg

Daytac Jan 19, 2013 at 12:43 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 7 comments
  • Avatar of Asixandur Asixandur Nov 11, 2013 at 12:43 UTC - 0 likes

    Can someone report if that has been fixed in last alpha?

  • Avatar of spikeles spikeles Nov 05, 2013 at 09:45 UTC - 0 likes

    Its due to changes in the way initialConfigFunction was changed in regards to secure templates, looks like many of the XPerl modules were fixed to work around or ignore this. Much of the code in other XPerl modules has been commented out when referring to initialConfigFunction

    Anyway, here's a fix I threw together by just removing most of the code for initialConfigFunction out into the init code. It seems to work based on my half second testing though you might have issues changing the width/height in combat.

    XPerl_RaidMonitor-fix.zip

    Last edited Nov 05, 2013 by spikeles: fix link to look nice, and spelling!
  • Avatar of PlayerLin PlayerLin Jan 20, 2013 at 10:09 UTC - 0 likes

    Glad someone ever noticed and report this again.

    It was broken by Blizzard's Great Patch 4.0 and no one ever know how to fix it until tickets cleared up. If Asixandur can't fix it then I guess that's it.. :(

  • Avatar of Asixandur Asixandur Jan 20, 2013 at 06:08 UTC - 0 likes

    I'll look into that issue, I can guarantee nothing. This module hasn't been updated for a long time and could be difficult to fix it.

  • Avatar of kunterkinte kunterkinte Jan 19, 2013 at 14:31 UTC - 0 likes

    Ja ihr Hampel was habt ihr dort für ein mist gemacht

  • Avatar of Gothicx Gothicx Jan 19, 2013 at 14:12 UTC - 0 likes

    the problem is real

  • Avatar of Drahacahador Drahacahador Jan 19, 2013 at 13:05 UTC - 1 like

    I totally agree. This has been bothering me as well. Would be great if you could make this happen. :)

  • 7 comments

Facts

Last updated
Nov 11, 2013
Reported
Jan 19, 2013
Status
Waiting - Waiting for more information.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
4

Reported by

Possible assignees