X-Perl UnitFrames

1241 - Player Frame not updating.

What steps will reproduce the problem?
1.Perform an action that will change the Player Frame, such as shapeshifting (ie caster > cat)

What is the expected output? What do you see instead?
Shapeshifting should update the 3D portrait and power bars. Shifting into Cat Form will show the energy bar, but blue instead of yellow. Portait retains model of initial form and doesn't update until the player frame is forced to update.
Opening and closing X-Perl config or the main map seems to force the frame to update

What version of the product are you using?
3.1.64    

Attached Screenshot shows disparity between player frame and current form.

  • WoWScrnShot_101311_152638.jpg
    In Cat Form, player frame shows ...
User When Change
PlayerLin Oct 24, 2011 at 11:02 UTC
BrknSoul Oct 15, 2011 at 03:41 UTC
PlayerLin Oct 14, 2011 at 11:57 UTC
BrknSoul Oct 14, 2011 at 04:49 UTC
PlayerLin Oct 13, 2011 at 11:05 UTC
BrknSoul Oct 13, 2011 at 05:02 UTC Changed description:
  What version of the product are you using?
  3.1.64

+ Attached Screenshot shows disparity between player frame and current form.

-
BrknSoul Oct 13, 2011 at 05:01 UTC

Added attachment WoWScrnShot_101311_152638.jpg

BrknSoul Oct 13, 2011 at 05:00 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 4 comments
  • Avatar of BrknSoul BrknSoul Oct 15, 2011 at 03:41 UTC - 0 likes
    <font color="7f7f7f">Removed/Renamed my XPerl*.lua files both under Server/SavedVariables and Server/Char/SavedVariables with no change. X-Perl reset to the default, but I'm still getting the blue energy bar/non-updating portrait.</font> <font color="7f7f7f">I'll try running X-Perl by itself and see what happens.</font>
    EDIT:
    Ok, my complete bad. I wrote my own mini-addon to move the eclipse bar. Looks like one of your recent updates (in regards to power bar docking) kinda broke my addon, which in turn broke the player frame. Following is my mini-addon that breaks the player frame;
    f = CreateFrame("Frame")
    f:SetScript("OnEvent",function()
    -- stuff to do on login goes after here
    EclipseBarFrame:ClearAllPoints();
    EclipseBarFrame:SetPoint("CENTER", "UIParent", "CENTER", 0, -210);
    EclipseBarFrame:Show();
    EclipseBarFrame:SetScale(1.15);
    -- stuff to do on login goes before here
    end)
    f:RegisterEvent("PLAYER_LOGIN")
    
    I can't check to see if the eclipse bar still moves, as my main account (with my boomkin) is frozen (forgot to buy more time :-P).
    EDIT:
    Ok, now it's only doing it randomly, but fixes itself after a reload. Hrmm. At least it's not stuck on full time.
    Last edited Oct 17, 2011 by BrknSoul
  • Avatar of PlayerLin PlayerLin Oct 14, 2011 at 11:57 UTC - 0 likes

    I cannot reproduce it with my Durid... I tried shifting any form except moonkin form(I don't have a balance durid)... in combat or non-combat, and only health bar height bug happens...the rest are fine at all...

    I was heard this bug long times ago but I cannot really remember what was wrong and other else...

    There is other bug cause some information on PlayerFrame like portrait frame, inspecting rep. bar, and some other small info do not update and will fixed after /reload or next login... So your problem isn't that one...

    Try this... Quit game, then deleted all your Xperlxxxxxxx.lua files in your WTF directory(you can backup them before you deleting them). After that, you can login your WoW and your character and X-Perl will refresh all its setting to default and see if it still not updating your PlayerFrame?

    Last edited Oct 14, 2011 by PlayerLin
  • Avatar of BrknSoul BrknSoul Oct 14, 2011 at 04:49 UTC - 0 likes

    /reloading my addons would force a player frame update, so, yes, /reload does refresh the player frame.

    After reloading, the bug still occurs.

  • Avatar of PlayerLin PlayerLin Oct 13, 2011 at 11:05 UTC - 0 likes

    Did you tried reload your addons with /reload? If not, try it and see is it still happens?

    If not...then I guess that known bug still happens. :\

    If still happens, maybe other glitches happens...

  • 4 comments

Facts

Last updated
Oct 24, 2011
Reported
Oct 13, 2011
Status
Duplicate - This report duplicates an existing ticket.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees