WIM (WoW Instant Messenger) v3

412 - Replying with default reply key

What steps will reproduce the problem?
1. Start a conversation
2. Get a whisper back
3. Reply with the shortcut reply key (default R)

What is the expected output? What do you see instead?
Latest window to open or get focus to enter your reply.
Instead I get a window where the previous name-realm goes in top of the window. When I enter my message there the reply does go into the last active window. To see the conversation I have to close this Name-Realm type window but each reply with <r> gives this window back. This only happens when
I had the last entry in the conversation. This only happens with the in game character chat, not with a bnet ID friend.

What version of the product are you using?
3.6.16 from curse

Do you have an error log of what happened?
No error involved

Please provide any additional information below.
The person I was in conversation was is in my friends list as well as in my battlenet ID list.

User When Change
ralnor Feb 24, 2014 at 20:50 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of wowza2 wowza2 Jan 10, 2015 at 16:12 UTC - 0 likes

    Get a whisper from someone on my server, shows as <name> (they are from my server)... However, when I hit "R" to reply, the reply makes a new window with <name>-Eonar (Eonar being the server I am on)

  • Avatar of Myrondanger Myrondanger Jan 02, 2015 at 07:45 UTC - 0 likes

    I am getting this same issue. Replying to someone from my current server opens a blank window xxxx-server which remains blank.

  • Avatar of doeboy09 doeboy09 Nov 22, 2014 at 07:52 UTC - 0 likes

    Coming back to this.

    I deleted everything and installed just WIM and still see this. Not sure why or what's going on at this point or why you can't repro it. I was hoping the update to version 6.0+ would help, but I still have the issue.

  • Avatar of mysticalos mysticalos Aug 12, 2014 at 20:09 UTC - 0 likes

    And it occurs with NO OTHER MOD running that could be conflicting with my realm filter code? as i said other mods like prat may break it because the problem is BLIZZARD is adding the realm, and I have to hack remove it. but if there is any other mod interfering with me FIXING blizzards stupid bug, then it gets underminded.

  • Avatar of doeboy09 doeboy09 Jul 23, 2014 at 05:25 UTC - 0 likes

    A little more info, this 'only' happens with characters I chat with on the same realm. It seems as though WIM get's confused and pops up the xxxx-Lothar tab when I hit [r] to reply. The weird thing is that the new window (the one I'm typing into) remains blank after I send the message.

  • Avatar of doeboy09 doeboy09 Jul 21, 2014 at 03:37 UTC - 0 likes

    Yes, I am on Lothar and this happens to all Lothar characters I message.

  • Avatar of mysticalos mysticalos Jul 21, 2014 at 00:45 UTC - 0 likes

    And lothar is the realm you are on? It will still have realm if the person is actually on a different realm. It'll strip it if they are on SAME realm. If it's not stripping I have no idea why. I don't see that problem. it strips when it's supposed to for me.

    This mess is ultimately blizzards fault. It's actually THEIR bug. WIM tries to work around it by removing realmname from outgoing whispers automatically. Since their replies will strip realm name on blizzards end (which is what causes double whisper windows if wim does not work around blizzards stupid /r bug adding realmname when it shouldn't)

    Last edited Jul 21, 2014 by mysticalos
  • Avatar of doeboy09 doeboy09 Jul 16, 2014 at 04:46 UTC - 0 likes

    I deleted my interface and WTF folders, re-installed only WIM and I still see this issue.

    As listed above, this does 'not' affect Battle.net. It only happens when I'm chatting to a character, when I hit [r] to respond, it opens up a new window with their name and realm name.

    IE: xxxx-Lothar

  • Avatar of mysticalos mysticalos Jun 30, 2014 at 21:11 UTC - 0 likes

    Possibly. Just try wim by itself. I just know I have code in place to prevent this exact issue bug if another mod is under-minding it by foolishly adding realm names where they don't belong then yes this would happen.

  • Avatar of schippie schippie Jun 30, 2014 at 18:59 UTC - 0 likes

    @alienns: Go

    Could it be because of ELVui? i am having the same problems so and seeing that elvui adds realm names could that be the issue?

Facts

Reported
Feb 24, 2014
Status
New - Issue has not had initial review yet.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees