WIM (WoW Instant Messenger) v3

341 - ERROR: Attempt to index local 'lastTell' (a nil value)

What steps will reproduce the problem?
1. hit the 'R' key to return a whisper
2.
3.

What is the expected output? What do you see instead?

Error message pops up

What version of the product are you using?

3.6

Do you have an error log of what happened?

Date: 2012-09-03 12:01:26
ID: 1
Error occured in: Global
Count: 1
Message: ..\AddOns\WIM\Modules\WhisperEngine.lua line 545:
attempt to index local 'lastTell' (a nil value)
Debug:
[C]: ?
WIM\Modules\WhisperEngine.lua:545:
WIM\Modules\WhisperEngine.lua:532
WIM\Modules\WhisperEngine.lua:618:
WIM\Modules\WhisperEngine.lua:618
[C]: ChatFrame_ReplyTell()
[string "REPLY"]:1:
[string "REPLY"]:1
Locals:
TellNotTold = true
curState = "other"
lastTell = nil
bNetID = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = 1
(*temporary) = 10
(*temporary) = "attempt to index local 'lastTell' (a nil value)"
_G = <table> {
ContainerFrame5Item7 = ContainerFrame5Item7 {
}
GetTrainerServiceTypeFilter = <function> defined =[C]:-1
UNIT_NAMES_COMBATLOG_TOOLTIP = "Color unit names."
SetTrainerServiceTypeFilter = <function> defined =[C]:-1
SPELL_FAILED_CUSTOM_ERROR_71 = "This partygoer wants to dance with you."
CompactUnitFrameProfilesGeneralOptionsFrameHealthTextDropdownButtonNormalTexture = CompactUnitFrameProfilesGeneralOptionsFrameHealthTextDropdownButtonNormalTexture {
}
XPerl_AssistsView_Close = <function> defined @Interface\AddOns\XPerl_RaidHelper\XPerl_AssistFrame.lua:118
PawnItemComparer = <function> defined @Interface\AddOns\Pawn\Pawn.lua:3075
Guild_Log_look_Roster = <function> defined @Interface\AddOns\Guild_Log\Guild_Log.lua:176
MultiBarLeftButton7 = MultiBarLeftButton7 {
}
AudioOptionsVoicePanelOutputDeviceDropDownButtonHighlightTexture = AudioOptionsVoicePanelOutputDeviceDropDownButtonHighlightTexture {
}
MerchantItem7AltCurrencyFrameItem1Text = MerchantItem7AltCurrencyFrameItem1Text {
}
BINDING_NAME_NAMEPLATES = "Show Enemy Name Plates"
CHAT_HEADER_SUFFIX = ": "
IsReferAFriendLinked = <function> defined =[C]:-1
RaidTray_Buff_OnUpdate = <function> defined @Interface\FrameXML\BuffFrame.lua:149
CalendarCreateEventInviteListScrollFrameButton12Name = CalendarCreateEventInviteListScrollFrameButton12Name {
}
QG_OPT_ANNOUNCE_CHANNEL_SAY = "/s"
ItemTextFrameInsetInsetTopRightCorner = ItemTextFrameInsetInsetTopRightCorner {
}
ERR_NOAMMO_S = "%s"
CalendarTodayTexture = CalendarTodayTexture {
}
GemHelper_UserDropdownIcon = GemHelper_UserDropdownIcon {
}
MoneyFrame_OnEvent = <function> defined @Interface\FrameXML\MoneyFrame.lua:233
WatchFrameItem_OnEvent = <function> defined @Interface\FrameXML\WatchFrame.lua:1367
InterfaceOptionsCombatTextPanelFCTDropDown_OnClick = <function> defined @Interface\FrameXML\InterfaceOptionsPanels.lua:1419
CalendarTexturePickerScrollFrameButton15Icon = CalendarTexturePickerScrollFrameButton15Icon {
}
LFGTeleport = <function> defined =[C]:-1
GetMonitorAspectRatio = <function> defined =[C]:-1
AtlasLootItem_30_QA = AtlasLootItem_30_QA {
}
ToggleEncounterJournal = <function> defined @Interface\FrameXML\UIParent.lua:617
Healium_UpdateButtonVisibility = <function> defined @Interface\AddOns\Healium\Healium.lua:814
Graphics_QualityText = Graphics_QualityText {
}
TalentMicroButtonAlertShadowTopLeft = TalentMicroButtonAlertShadowTopLeft {
}
CompactUnitFrameProfilesSaveButton = CompactUnitFrameProfilesSaveButton {
}
ACTION_SPELL_MISSED_POSSESSIVE = "1"
XPERL_RAID_TOOLTIP_BUFFEXPIRING = "%s's %s expires in %s"
Is64BitClient = <function> defined =[C]:-1
ATSWRFReagent3InventoryText = ATSWRFReagent3InventoryText {
}
GemHelper_CheckButton35Text = GemHelper_CheckButton35Text {
}
InterfaceOptionsCombatTextPanelRepChanges = InterfaceOptionsCombatTextPanelRepChanges {
}
TutorialFrame_OnMouseDown = <function> defined @Interface\FrameXML\TutorialFrame.lua:670
SortQuestWatches = <function> defined =[C]:-1
ContainerFrame4Item16Cooldown = ContainerFrame4Item16Cooldown {
}
XPerl_RaidFrameDropDown_Initialize = <function> defined @Interface\AddOns\XPerl_RaidFrames\XPerl_Raid.lua:213
AudioOptionsVoicePanel_OnShow = <function> defined @Interface\FrameXML\AudioOptionsPanels.lua:325
XPerl_PlayerstatsFramexpRestBarpercent = XPerl_PlayerstatsFramexpRestBarpercent {
}
SPELL_FAILED_CUSTOM_ERROR_152 = "You must choose a specialization to use Ascendance."
LAG_TOLERANCE = "Lag Tolerance"
TradeSkillFilterDropDownRight = TradeSkillFilterDropDownRight {
}
SendStationeryBackgroundRight = SendStationeryBackgroundRight {
}
ChannelRoster_Update = <function> defined @Interface\FrameXML\ChannelFrame.lua:584
TUTORIAL61_SPELLID_DRUID = "768"
MultiBarLeftButton9Border = MultiBarLeftButton9Border {
}
b = LuckyCharm0 {
}
i = 40
OPTION_TOOLTIP_SHOW_ACCOUNT_ACHIEVEMENTS = "Tur

Please provide any additional information below.

User When Change
mysticalos Sep 06, 2012 at 13:11 UTC
mysticalos Sep 06, 2012 at 13:08 UTC
Aoife Sep 03, 2012 at 19:05 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 1 comment
  • Avatar of mysticalos mysticalos Sep 06, 2012 at 13:01 UTC - 0 likes

    i could not reproduce this problem but i silenced error with a nil check, it may not actually fix the problem for you though as it might still not actually reply to whisper if lastTell is nil for some reason.

  • 1 comment

Facts

Last updated
Sep 06, 2012
Reported
Sep 03, 2012
Status
Duplicate - This report duplicates an existing ticket.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees