WeakAuras 2

36 - Auto-cloned auras do not respect 'All Triggers' w/ add'l triggers.

What steps will reproduce the problem?
1.  Create an 'Aura' type trigger, set it to Multi-target, set the aura to something you can cast ("Guardian Spirit", for instance).
2.  Click "Add Trigger", Choose Trigger "Trigger 2", type Custom, event type Event, Event(s) COMBAT_LOG_EVENT_UNFILTERED.

function(event, timeStamp, subevent, _, sourceGUID, sourceName, _, _, destGUID, destName, _, _, ...)
    if subevent == 'SPELL_AURA_APPLIED' then
        local spellId, spellName, spellSchool, auraType = ...

        if destName == 'Hekili' then
            return false
        else
            return true
        end
    end
    return false
end

3.  Set required for activation, "All Triggers."

What is the expected output? What do you see instead?

The first trigger should succeed when someone casts Guardian Spirit.
The second trigger should exclude when the spell is cast on Hekili.

I've also tested this using the UNIT_AURA event.

Only the first trigger is being respected, even though the second trigger is running (putting in some debug prints shows this).

What version of the product are you using?
WeakAuras 2 r29

Do you have an error log of what happened?
There is no error.

Please provide any additional information below.
Ultimately, I'm just trying to workaround the fact that we can't have auto-cloning on Custom triggers.  It'd be nicer if we *could* auto-clone Custom triggers (perhaps require a specific set of return values to make that work?), but otherwise, I'd like to find a sane workaround.

User When Change
InfusOnWow Dec 13, 2014 at 15:47 UTC Changed status from New to Invalid
kapulani Dec 17, 2013 at 19:59 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 1 comment
  • Avatar of InfusOnWow InfusOnWow Dec 13, 2014 at 15:49 UTC - 0 likes

    The first trigger is active if anyone in the group/raid has a Guardian Spirit buff. The second one is active for every SPELL_AURA_APPLIED, except a few. (and presumably active for a short duration)

    Since there always SPELL_AURA_APPLIED events happening, this trigger will always be active.

  • 1 comment

Facts

Last updated
Dec 13, 2014
Reported
Dec 17, 2013
Status
Invalid - This was not a valid report.
Type
Other - Some other kind of issue
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees