WeakAuras 2

35 - Specific auras blow up Weak Auras on relog

What steps will reproduce the problem?
1. Create a group of three (specific) auras dealing with in-game events
2. Relog
3. Addon explodes
4. Fixing addon requires excising the auras from WeakAuras.lua (savedvariable)

What is the expected output? What do you see instead?
A group of three auras. Instead, upon logging in, *all* auras are displayed with question mark icons and all text fields reading ERROR. The aura list displays almost no auras, and none can be changed.

What version of the product are you using?
2.0.3

Do you have an error log of what happened?
No log

Please provide any additional information below.

Prepare for spam. The auras are SUPPOSED to use Combat Log entries and events to track and display the ICD of Blade of the Hundred Steps, the Tank buff on Spoils. This is the second time I've created this aura group, with the same results each time. Breakdown of each of the three auras follows.

BLADE PROC:

    Trigger Combat Log, Spell damage, Blade of the Hundred Steps

    Custom Hide 15s

    ON SHOW
    custom
WA_Blade_Proc = true
WeakAuras.ScanEvents("WA_BLADE_DAMAGE")

    ON HIDE
    custom
WA_Blade_Proc = nil
WeakAuras.ScanEvents("WA_BLADE_DAMAGE")

BLADE TIMER: (Bar)

    Trigger Custom Status Event(s) WA_BLADE_DAMAGE
    (Trigger 2, Simple Aura: Blade of the Hundred Steps)
    Custom Trigger: function() return WA_Blade_Proc end
    Custom Untrigger: function() return not WA_Blade_Proc end
    Custom Duration: 15
    
    ON SHOW
    custom
WA_Blade_CD = nil
WeakAuras.ScanEvents("WA_BLADE_READY")

    ON HIDE
    custom
WA_Blade_CD = True
WeakAuras.ScanEvents("WA_BLADE_READY")

BLADE READY:

    Trigger Custom Status Event(s) WA_BLADE_READY
    (Trigger 2, Simple Aura: Blade of the Hundred Steps)
    
Custom Trigger: function() return WA_Blade_CD end
Custom Untrigger: function() return not WA_Blade_CD end

Name Description Size MD5
Problem_Auras.lua Problem auras chopped out of ... 8.9 KiB 8075b7536ce1...
User When Change
InfusOnWow Jan 22, 2015 at 22:56 UTC Changed status from New to Invalid
kingoomieiii Dec 16, 2013 at 07:12 UTC

Added attachment Problem_Auras.lua

kingoomieiii Dec 16, 2013 at 07:11 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 1 comment
  • Avatar of InfusOnWow InfusOnWow Jan 22, 2015 at 23:00 UTC - 0 likes

    Sorry for not responding faster. The reason those auras lead to unrecoverable errors is likely that you call WeakAuras.ScanEvents() manually in your on show and on hide actions. These functions are also called on opening the options dialog. That shouldn't break the options dialog, but calling those functions is inherently unsupportable. Still if you have those auras exported to a string, I'd take a look on why exactly that leads to problems. Having them in the lua text format isn't as convenient to import.

  • 1 comment

Facts

Last updated
Jan 22, 2015
Reported
Dec 16, 2013
Status
Invalid - This was not a valid report.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees