Vex Power

16 - Warrior's rage 5.2

What steps will reproduce the problem?
Log on to Warrior

What is the expected output? What do you see instead?

Addon doesn't load properly

What version of the product are you using?
1.12.4

Do you have an error log of what happened?
<<code>>51x vexpower-1.12.4\core\text.lua:124: Usage: UnitBuff("unit", [index] or ["name", "rank"][, "filter"]) <in C code> vexpower-1.12.4\core\text.lua:124: in function "vexpower_Text_getTimeBuff" vexpower-1.12.4\core\text.lua:71: in function "vexpower_Text_getTimeData" vexpower-1.12.4\core\text.lua:22: in function "vexpower_Text_parseTagInfo" vexpower-1.12.4\core\text.lua:11: in function "vexpower_Text_change" vexpower-1.12.4\core\initialize.lua:43: in function "vexpower_initialize" vexpower\vexpower-1.12.4.lua:65: in function <vexpower\vexpower.lua:63>

Locals: type = "total" returnvalue = "" auraid = 125831 buffname = nil<</code>>

User When Change
fuda01 Jul 08, 2013 at 16:26 UTC
tordenflesk Mar 08, 2013 at 01:06 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 3 comments
  • Avatar of fuda01 fuda01 Jul 03, 2013 at 18:48 UTC - 0 likes

    Hi, I just reinstalled World of Warcraft, but since I dont have a high lvl warrior and the PTRs are down I just changed the spell ID like Kimi3013 suggested. Hope it's fixed and thank you Kimi.

    Cheers, fuda

  • Avatar of Kimi3013 Kimi3013 Apr 15, 2013 at 16:07 UTC - 0 likes

    I assume this is the same problem I had when 5.2 came out. The issue is with the change to Taste for Blood for Arms. The addon used to track stacks of Taste for Blood on the 'combo point' bar, but when they changed it to give Overpower charges instead they deleted the old buff and created a new one with a new ID.

    I think the only change I made was to /core/cps.lua line 190. Change the numbers from whatever they are (125831 I'd expect based on the error) to 60503 instead. Then it should work fine.

  • Avatar of VoxxMan VoxxMan Apr 13, 2013 at 18:19 UTC - 0 likes

    Same issue here. In addition to this error, i still see the rage bar but /vexp doesn't do anything (in fact you can't even press enter after typing /vexp ) and there is no entry in the interface-addon menu of wow either.

    Otherwise this works fine on my monk, rogue, warlock and hunter.

  • 3 comments

Facts

Last updated
Jul 08, 2013
Reported
Mar 08, 2013
Status
Fixed - Developer made requested changes. QA should verify.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
1

Reported by

Possible assignees