Vanas KoS

69 - Error loading vanaskos and during games errors

What steps will reproduce the problem?
1.as soon as the game loads
2.as soon as you enter a dungeon/raid
3.as soon as someone enter your party

What version of the product are you using?
4.44
This is the error log created by swatter with swatter and vanaskos turned on, nothing else:

Quote:

Date: 2013-03-20 15:25:35
ID: 1
Error occured in: Global
Count: 1
Message: ..\AddOns\VanasKoS\modules\EventMap.lua line 260:
attempt to index global 'WorldMapPlayer' (a nil value)
Debug:
VanasKoS\modules\EventMap.lua:260: drawPOI()
VanasKoS\modules\EventMap.lua:366: CreatePoints()
VanasKoS\modules\EventMap.lua:412: UpdatePOI()
VanasKoS\modules\EventMap.lua:601: ?()
...KoS\Libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:147:
...KoS\Libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:147
[string "safecall Dispatcher[1]"]:4:
[string "safecall Dispatcher[1]"]:4
[C]: ?
[string "safecall Dispatcher[1]"]:13: ?()
...KoS\Libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:92: Fire()
...e\AddOns\VanasKoS\Libs\AceEvent-3.0\AceEvent-3.0.lua:120:
...e\AddOns\VanasKoS\Libs\AceEvent-3.0\AceEvent-3.0.lua:119
Locals:
None
AddOns:
Swatter, v4.2.0 (<%codename%>)
VanasKoS, v4.44-$Rev: 520 $
BlizRuntimeLib_enUS v5.2.0.50200 <eu>
(ck=67)

Please provide any additional information below.
ty for your effort we apreciated it very much
insa

UPDATE

AS STATED BY BADBOY442 ON VANAS KOS PAGE ON CURSE:

Quote:

badboy442
I could fix this with changing the "WorldMapPlayer" in file "EventMap.lua" to "WorldMapPlayerUpper" in line 260.
I don't know if it really fixed it since LUA isn't my language but I got rid of that error so maybe try it?

error is gone but i don't know if it is a real fix or not.

kudos to badboy442

User When Change
Vana May 20, 2013 at 21:12 UTC
insanes Apr 03, 2013 at 08:21 UTC Changed description:
  Please provide any additional information below.
  ty for your effort we apreciated it very much
  insa
+
+ [b]UPDATE[/b]
+
+ AS STATED BY BADBOY442 ON VANAS KOS PAGE ON CURSE:
+ [quote]
+  badboy442
+ I could fix this with changing the "WorldMapPlayer" in file "EventMap.lua" to "WorldMapPlayerUpper" in line 260.
+ I don't know if it really fixed it since LUA isn't my language but I got rid of that error so maybe try it?[/quote]
+
+ error is gone but i don't know if it is a real fix or not.
+
+ kudos to badboy442
insanes Mar 20, 2013 at 14:38 UTC Changed description:
  What steps will reproduce the problem?
  1.as soon as the game loads
- 2.as soos as you enter a dungeon/raid
+ 2.as soon as you enter a dungeon/raid
- 3.as soos as someone enter your party
+ 3.as soon as someone enter your party
  What version of the product are you using?
  4.44
insanes Mar 20, 2013 at 14:36 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

Facts

Last updated
May 20, 2013
Reported
Mar 20, 2013
Status
Fixed - Developer made requested changes. QA should verify.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees