TradeFilter

6 - Possible Bug?

What steps will reproduce the problem?
1. Join raid or party and the below error pops up in bugsack

What version of the product are you using?
v3.4.5 for 4.0.3a

Do you have an error log of what happened?

46x TradeFilter3-v3.4.5\TradeFilter3.lua:267: Usage: GetPartyMember(1-4)
TradeFilter3-v3.4.5\TradeFilter3.lua:267: in function <TradeFilter3\TradeFilter3.lua:259>
(tail call): ?:
<in C code>: ?
<string>:"safecall Dispatcher[2]":9: in function <[string "safecall Dispatcher[2]"]:5>
(tail call): ?:
AceTimer-3.0-5 (Ace3):164: in function <Ace3\AceTimer-3.0\AceTimer-3.0.lua:138>

-

Please provide any additional information below.

Worked fine prior to last update. Apologises if its not trade filters problem

User When Change
networkerror Feb 01, 2011 at 00:11 UTC Changed status from Replied to Fixed
Uggrich Jan 29, 2011 at 01:23 UTC Changed status from Waiting to Replied
networkerror Jan 29, 2011 at 01:01 UTC Changed status from Replied to Waiting
networkerror Jan 28, 2011 at 06:19 UTC

Deleted attachment TradeFilter3.diff: bad diff

networkerror Jan 28, 2011 at 06:17 UTC

Added attachment 0001-Fix-GetParty-raid-party-exempt-list-AceTimer-issue.-.patch

networkerror Jan 28, 2011 at 06:17 UTC

Added attachment TradeFilter3.diff

Uggrich Jan 26, 2011 at 23:20 UTC Changed status from Waiting to Replied
networkerror Jan 26, 2011 at 22:12 UTC Changed status from Replied to Waiting
Uggrich Jan 26, 2011 at 11:42 UTC Changed status from Waiting to Replied
networkerror Jan 26, 2011 at 07:05 UTC Changed status from Accepted to Waiting
networkerror Jan 26, 2011 at 06:54 UTC Changed status from New to Accepted
Uggrich Jan 25, 2011 at 19:41 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of networkerror networkerror Feb 01, 2011 at 00:11 UTC - 0 likes

    Very good, marking this as fixed. Thanks for the report and your time getting it hashed out, if you find anymore bugs let me know.

  • Avatar of Uggrich Uggrich Jan 31, 2011 at 19:45 UTC - 0 likes

    Just done a few boss attempts and seems to be all good now.

    no bug sack warnings :)

  • Avatar of Uggrich Uggrich Jan 31, 2011 at 10:50 UTC - 0 likes

    Will do, let you know later this evening :)

  • Avatar of networkerror networkerror Jan 31, 2011 at 07:29 UTC - 0 likes

    Ok Uggrich try g0f7b08f, some testing in BG's and parties it should be working as intended please verify.

  • Avatar of networkerror networkerror Jan 30, 2011 at 23:24 UTC - 0 likes

    Ok I will get do some battlegrounds tonight to see if I can kill this problem for good.

  • Avatar of Uggrich Uggrich Jan 30, 2011 at 18:58 UTC - 0 likes

    Scratch that, entered the raid and kept on spamming sorry,

    Gone back to v3.4.4 for the time being the pre AceTimer one

    Last edited Jan 30, 2011 by Uggrich
  • Avatar of Uggrich Uggrich Jan 30, 2011 at 13:33 UTC - 0 likes

    Seems alright now, Got a raid this evening so i'll double check.

    Yeah seems pretty fine now, I'll let you know if anything crops up but nothing so far :) thanks for all the hard work

    Last edited Jan 30, 2011 by Uggrich
  • Avatar of Uggrich Uggrich Jan 29, 2011 at 01:23 UTC - 0 likes

    Will do, will give you an update in about 12 hours when I raid again, Sorry for all the work :)

  • Avatar of networkerror networkerror Jan 29, 2011 at 01:01 UTC - 0 likes

    Ok the WowAce packager appears to be back in business so please give g0f22db4 a try.

  • Avatar of Uggrich Uggrich Jan 28, 2011 at 16:16 UTC - 0 likes

    Sorry excuse my stupidity but not sure what to do with that patch file, if it is indeed for me to do anything with :P

Facts

Last updated
Feb 01, 2011
Reported
Jan 25, 2011
Status
Fixed - Developer made requested changes. QA should verify.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees