SmartMount

62 - Smartmount tries to use flying mount during Wintergrasp Battle

What steps will reproduce the problem?
1. Join or fly to Wintergrasp during Battle
2. try to mount via SmartMount

What is the expected output? What do you see instead?
expected: Mount with ground mount. what happens: error 'can't do that now' because smartmount trys to mount with flyable mount

What version of the product are you using?
v3.3-100

User When Change
akazik Feb 28, 2010 at 19:21 UTC Changed status from Started to Fixed
akazik Feb 27, 2010 at 17:33 UTC Changed status from Accepted to Started
akazik Feb 25, 2010 at 16:26 UTC Changed status from New to Accepted
Aratar Feb 24, 2010 at 16:08 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 2 comments
  • Avatar of akazik akazik Feb 25, 2010 at 16:26 UTC - 0 likes

    Hi,

    I'm sorry...

    I thought that the new behavior of blizzards is flyable function does also handle that (like all the other things).

    I'll reinclude it.

    Ciao, ALeX.

  • Avatar of Aratar Aratar Feb 24, 2010 at 16:21 UTC - 0 likes

    This seems to be new bug since r99,

    simply readd

    if (zone == self.SpellLocale['Wintergrasp'] and not GetWintergraspWaitTime()) then in Wintergrasp: no flying allowed self:dump('flyable', 'no: dalaran|wintergrasp') return false end if

    to function SmartMount:CanFlyHere(zone, subzone) and the corresponding spell locales should fix it again

  • 2 comments

Facts

Last updated
Feb 28, 2010
Reported
Feb 24, 2010
Status
Fixed - Developer made requested changes. QA should verify.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees