Skada Damage Meter

168 - LibFail 2.0 Support

Skada only supports libfail 1.0, which does not contain cataclysm events.

User When Change
Zarnivoop May 06, 2011 at 07:47 UTC Changed status from New to Fixed
schizo Jan 07, 2011 at 22:44 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 3 comments
  • Avatar of Zarnivoop Zarnivoop May 06, 2011 at 07:47 UTC - 0 likes

    Removed Failbot module. LibFail 2.0 has too many dependencies for something included in the main Skada addon. Will add a plug for SkadaEnsidiaFails instead.

  • Avatar of Maat Maat Jan 15, 2011 at 19:38 UTC - 0 likes

    also add

    	if not Skada.modules.Fails.enabledState then return end
    

    to the onFail function

  • Avatar of Maat Maat Jan 15, 2011 at 12:31 UTC - 0 likes

    I've quickly updated your Failbot module to support LibFail-2.0 you can find the diff here

    You'll need to make sure the following libraries are loaded since they are required for LibFail-2.0:

    • LibBabble-Boss-3.0
    • LibBabble-Zone-3.0
    • LibTalentQuery-1.0
    • LibGroupTalents-1.0

    Also LibTalentQuery-1.0 needs to be loaded before LibGroupTalents-1.0

    If people are looking for a more "complete" fail display, check out: SkadaEnsidiaFails. It uses EnsidiaFails filtering options to display fails in Skada. It also has an event view not just a player view.

  • 3 comments

Facts

Last updated
Mar 30, 2012
Reported
Jan 07, 2011
Status
Fixed - Developer made requested changes. QA should verify.
Type
Enhancement - A change which is intended to better the project in some way
Priority
Medium - Normal priority.
Votes
8

Reported by

Possible assignees