Shadowed Unit Frames

703 - Raid pets anchor issue

What steps will reproduce the problem?
1. Anchor raid pets to raid frames
2. Set raid frames to "separate raid frames"
3. Change the anchor settings around for Raid pets

What is the expected output? What do you see instead?
Raid pets are expected to anchor to the visible raid frames, instead they anchor to where the frames WOULD be if "separate raid frames" were not checked.

What version of the product are you using?
3.10.7

Do you have an error log of what happened?
nope

Please provide any additional information below.

User When Change
JagScorpion Apr 24, 2014 at 12:31 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 4 comments
  • Avatar of Shadowed Shadowed Apr 27, 2014 at 04:34 UTC - 0 likes

    Can you provide a SS of this? Would make it slightly easier to visualize as these kind of issues are a pain to replicate.

  • Avatar of JagScorpion JagScorpion Apr 25, 2014 at 07:35 UTC - 0 likes

    Raid(A)Pet Raid Raid _ (?)RPaeitd Raid Raid

    tried to do a text diagram, but formatting messed that up, heh In both cases the anchor is supposed to be right top "A", but in the 2nd case it seems to revert to (?) even though the raid pet frame still shows "right top"

    something else I just noticed, with separate raid frames, changing the anchor position doesn't have the slightest effect even after a /rl. I wouldn't worry so much, and just go with the NON separated raid frames except it just doesn't seem to work well with a changing number of people in raid, such as a bg filling up

    Last edited Apr 25, 2014 by JagScorpion
  • Avatar of JagScorpion JagScorpion Apr 25, 2014 at 07:22 UTC - 0 likes

    @Shadowed: Go

    it fixes it in some ways, but the raid pet frames behave strangely, for example, I made a "separated" raid frames config 2 columns wide, and the non separated config 4 columns wide. Non-separated, the left edge of the raid pets frame is flush with the far right edge of the right-most column, switching to separate raid frames and /rl results in the left edge of the raid pets frame being flush with the left edge of the leftmost raid frame, in essence 3/4ths of the raid pets are competing for space. It's like it forgot where the top right anchor is supposed to be, not to mention that it's difficult to configure if every change needs a /rl

    In addition, when joining a raid the pet frames seem to have the same difficulty, either ending up smudged into the raid windows, or super far outside them. Trying to put up screenshots, but imggur is not being nice

  • Avatar of Shadowed Shadowed Apr 24, 2014 at 23:34 UTC - 0 likes

    Doing a /console reloadui fixes this correct? So it's only an issue when doing a config change.

  • 4 comments

Facts

Reported
Apr 24, 2014
Status
New - Issue has not had initial review yet.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees