Routes

64 - Bug immed. upon login

I'm on Mists 5.0.5.

Fresh install of Routes (no existing routes) and only the gathermate2 data (not the gathermate2 addon itself) are enabled.

I went outside the Orgrimmar gates into Durotar zone, then typed /routes in the chat window. The initial Routes panel appeared just fine but when I clicked on "Add," this error appeared:
_______

Message: ...utes\Libs\AceGUI-3.0\widgets\AceGUIWidget-Button.lua:66 CreateFrame(): Couldn't find inherited node "UIPanelButtonTemplate2"
Time: 10/04/12 11:29:00
Count: 1
Stack: [C]: ?
...utes\Libs\AceGUI-3.0\widgets\AceGUIWidget-Button.lua:66 in function `?'
...terface\AddOns\Routes\Libs\AceGUI-3.0\AceGUI-3.0.lua:136 in function <...terface\AddOns\Routes\Libs\AceGUI-3.0\AceGUI-3.0.lua:125
...terface\AddOns\Routes\Libs\AceGUI-3.0\AceGUI-3.0.lua:174 in function `Create'
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1116 in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1054
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1581 in function `FeedGroup'
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1506 in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:1486
(tail call): ?
[C]: ?
[string "safecall Dispatcher[3]"]:9: in function <[string "safecall Dispatcher[3]"]:5>
(tail call): ?
...terface\AddOns\Routes\Libs\AceGUI-3.0\AceGUI-3.0.lua:314 in function `Fire'
...ibs\AceGUI-3.0\widgets\AceGUIContainer-TreeGroup.lua:504 in function `SetSelected'
...ibs\AceGUI-3.0\widgets\AceGUIContainer-TreeGroup.lua:192 in function <...ibs\AceGUI-3.0\widgets\AceGUIContainer-TreeGroup.lua:188

Locals: <none>
_______

I thought maybe having the gathermate2 addon (not the data) disabled might be a problem so I enabled it. I got *exactly* the same error as above, but this time the error appeared when I entered WoW on my toon (before, it didn't appear until I tried to add the first route).

I logged out of WoW and disabled the gathermate2 addon (not the data), thinking that I'd go back to the point where the error didn't appear upon login but when I logged into WoW again, this error appeared immediately:
_______

Message: Interface\AddOns\Routes\Modules\AutoShow.lua:21 table index is nil
Time: 10/04/12 11:36:32
Count: 1
Stack: Interface\AddOns\Routes\Modules\AutoShow.lua:21 in main chunk

Locals: Routes = <table> {
 SetDefaultModuleLibraries = <function> defined @Interface\AddOns\Routes\Libs\AceAddon-3.0\AceAddon-3.0.lua:383
 TSP = <table> {
 }
 EnableModule = <function> defined @Interface\AddOns\Routes\Libs\AceAddon-3.0\AceAddon-3.0.lua:348
 modules = <table> {
 }
 IterateEmbeds = <function> defined @Interface\AddOns\Routes\Libs\AceAddon-3.0\AceAddon-3.0.lua:458
 SecureHookScript = <function> defined @Interface\AddOns\Routes\Libs\AceHook-3.0\AceHook-3.0.lua:413
 CVAR_UPDATE = <function> defined @Interface\AddOns\Routes\Routes.lua:1058
 RawHookScript = <function> defined @Interface\AddOns\Routes\Libs\AceHook-3.0\AceHook-3.0.lua:398
 Printf = <function> defined @Interface\AddOns\Routes\Libs\AceConsole-3.0\AceConsole-3.0.lua:69
 DeleteNode = <function> defined @Interface\AddOns\Routes\Routes.lua:811
 defaultModuleState = true
 IsEnabled = <function> defined @Interface\AddOns\Routes\Libs\AceAddon-3.0\AceAddon-3.0.lua:467
 DrawMinimapLines = <function> defined @Interface\AddOns\Routes\Routes.lua:394
 DisableModule = <function> defined @Interface\AddOns\Routes\Libs\AceAddon-3.0\AceAddon-3.0.lua:366
 getID = <function> defined @Interface\AddOns\Routes\Routes.lua:229
 ADDON_LOADED = <function> defined @Interface\AddOns\Routes\Routes.lua:1095
 RegisterMessage = <function> defined @Interface\AddOns\Routes\Libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:118
 UnregisterMessage = <function> defined @Interface\AddOns\Routes\Libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:181
 GetAceOptRouteTable = <function> defined @Interface\AddOns\Routes\Routes.lua:2181
 hooks = <table> {
 }
 SetEnabledState = <function> defined @Interface\AddOns\Routes\Libs\AceAddon-3.0\AceAddon-3.0.lua:440
 Hook = <function> defined @Interface\AddOns\Routes\Libs\AceHook-3.0\AceHook-3.0.lua:277
 enabledState = true
 RegisterEvent = <function> defined @Interface\AddOns\Routes\Libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:118
 routekeys = <table> {
 }
 IterateModules = <function> defined @Interface\AddOns\Routes\Libs\AceAddon-3.0\AceAddon-3.0.lua:453
 RawHook = <function> defined @Interface\AddOns\Routes\Libs\AceHook-3.0\AceHook-3.0.lua:316
 mapData = <table> {
 }
 UpgradeStorageFormat1 = <function> defined @Interface\AddOns\Routes\Routes.lua:879
 OnInitialize = <function> defined @Interface\AddOns\Routes\Routes.lua:957
 UnregisterAllEvents = <function> defined @Interface\AddOns\Routes\Libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:202
 IsNodeInTaboo = <function> defined @Interface\AddOns\Routes\Routes.lua:3329
 DrawTaboo = <function> defined @Interface\AddOns\Routes\Routes.lua:2606
 GetModule = <function> defined @Interface\AddOns\Routes\Libs\AceAddon-3.0\AceAddon-3.0.lua:231
 plugins = <table> {
 }
 defaultModuleLibraries = <table> {
 }
 UnregisterChatCommand = <function> defined @Interface\AddOns\Routes\Libs\AceConsole-3.0\AceConsole-3.0.lua:111
 KeybindHelper = <table> {
 }
 SetupSourcesOptTables = <function> defined @Interface\AddOns\Routes\Routes.lua:2283
 GetName = <function> defined @Interface\AddOns\Routes\Libs\AceAddon-3.0\AceAddon-3.0.lua:300
 name = "Routes"
 orderedModules = <table> {
 }
 Disable = <function> defined @Interface\AddOns\Routes\Libs\AceAddon-3.0\AceAddon-3.0.lua:330
 ReparentMinimap = <function> defined @Interface\AddOns\Routes\Routes.lua:3532
 OnEnable = <function> defined @Interface\AddOns\Routes\Routes.lua:1064
 ApplyTabooToRoute = <function> defined @Interface\AddOns\Routes\Routes.lua:3360
 GetAceOptRouteEditTable = <function> defined @Interface\AddOns\Routes\Routes.lua:3283
 GetAceOptTabooTable = <function> defined @Interface\AddOns\Routes\Routes.lua:3131
 HookScript = <function> defined @Interface\AddOns\Routes\Libs\AceHook-3.0\AceHook-3.0.lua:369
 G = <table> {
 }
 DrawTaboos = <function> defined @Interface\AddOns\Routes\Routes.lua:2693

_______

As others have already said, the Routes addon has served me well for a long time. I know you're going through your addons and that you get an email for each comment, and I appreciate you time; especially since you haven't started leveling MoP yet.

I hope this detailed info helps you to narrow down what needs to be fixed. Peace....

=============================================================
Hopefully, my narrative (above) answers the template questions (below)   :-)

What steps will reproduce the problem?
1.
2.
3.

What is the expected output? What do you see instead?

What version of the product are you using?

Do you have an error log of what happened?

Please provide any additional information below.

User When Change
richh2 Oct 04, 2012 at 15:44 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

Facts

Reported
Oct 04, 2012
Status
New - Issue has not had initial review yet.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees