RaidBuffStatus

400 - Blood Death Knight role detection broken

What steps will reproduce the problem?
1. Get a Blood Death Knigh in your raid.
2. Check the spec window.

What is the expected output? What do you see instead?
It should show the Death Knight with a tank role, but instead it shows a question mark.

What version of the product are you using?
5.9.0

Do you have an error log of what happened?
No errors are thrown.

Please provide any additional information below.
I don't know when this started, but it worked fine until a few months or weeks ago. Right now it seems to happen all the time, so e.g. a relog doesn't fix it.
I've tried the refresh button in the spec window, it also doesn't fix the problem.
An effect of this problem is that the Death Knight is reported with a wrong Presence, that's how I noticed it.

  • WoWScrnShot_032614_194611.jpg
User When Change
cremor Jun 25, 2014 at 20:31 UTC Changed status from New to Invalid
cremor Mar 31, 2014 at 15:26 UTC

Added attachment WoWScrnShot_032614_194611.jpg

cremor Mar 31, 2014 at 15:25 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 2 comments
  • Avatar of cremor cremor Jun 25, 2014 at 20:30 UTC - 0 likes

    Sorry for taking so long to respond. It seems like I can't reproduce it any more. In case I'll see it again I'll reopen the ticket with the requested information.

  • Avatar of oscarucb oscarucb May 04, 2014 at 11:45 UTC - 0 likes

    I'm not able to reproduce this problem on my enUS client.

    My best guess is something wrong with LibGroupInSpecT-1.0, possibly language specific.

    Next time it happens, target the DK and screenshot the output of this command:

    /dump LibStub("LibGroupInSpecT-1.0"):GetCachedInfo(UnitGUID("target"))

  • 2 comments

Facts

Last updated
Jun 25, 2014
Reported
Mar 31, 2014
Status
Invalid - This was not a valid report.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees