Prat 3.0

556 - Taint still present in r876

This is a continuation of ticket 527.  That ticket is marked as fixed, but the error is still present in the latest version with different line numbers.

What steps will reproduce the problem?
1. Run the addon
2.
3.

What is the expected output? What do you see instead?
No taint.  Taint in the taint log.

What version of the product are you using?
r876

*IMPORTANT* -> Can you reproduce the problem when ONLY Prat is running?
The issue is difficult to reproduce, it only happens sometimes.  I believe it tends to happen when you zone in when in combatlog.

Do you play on US or EU. What language do you use?
US.

Do you have an error log of what happened?

9/20 00:55:36.769  Global variable Prat tainted by Prat-3.0 - Interface\AddOns\Prat-3.0\addon\addon.lua:30
9/20 00:55:36.769  Execution tainted by Prat-3.0 while reading Prat - Interface\AddOns\Prat-3.0\modules\Timestamps.lua:512
9/20 00:55:36.769      Interface\AddOns\Prat-3.0\addon\addon.lua:705
9/20 00:55:36.769      Interface\FrameXML\UIParent.lua:783
9/20 00:55:36.769      PartyMemberFrame1:SetAttribute()
9/20 00:55:36.769      Interface\FrameXML\UnitFrame.lua:77 UnitFrame_SetUnit()
9/20 00:55:36.769      Interface\FrameXML\PartyMemberFrame.lua:44 PartyMemberFrame_ToPlayerArt()
9/20 00:55:36.769      Interface\FrameXML\PartyMemberFrame.lua:27 PartyMemberFrame_UpdateArt()
9/20 00:55:36.769      Interface\FrameXML\PartyMemberFrame.lua:335 PartyMemberFrame_OnEvent()
9/20 00:55:36.769      *:OnEvent:1 PartyMemberFrame1:OnEvent()
9/20 00:55:36.769      Interface\FrameXML\UnitFrame.lua:483
9/20 00:55:36.769  An action was blocked in combat because of taint from Prat-3.0 - PartyMemberFrame1:SetAttribute()
9/20 00:55:36.769      Interface\FrameXML\UnitFrame.lua:77 UnitFrame_SetUnit()
9/20 00:55:36.769      Interface\FrameXML\PartyMemberFrame.lua:44 PartyMemberFrame_ToPlayerArt()
9/20 00:55:36.769      Interface\FrameXML\PartyMemberFrame.lua:27 PartyMemberFrame_UpdateArt()
9/20 00:55:36.769      Interface\FrameXML\PartyMemberFrame.lua:335 PartyMemberFrame_OnEvent()
9/20 00:55:36.769      *:OnEvent:1 PartyMemberFrame1:OnEvent()
9/20 00:55:36.769      Interface\FrameXML\UnitFrame.lua:483
9/20 00:55:36.785  Global variable INTERFACE_ACTION_BLOCKED_SHOWN tainted by Prat-3.0 - Interface\FrameXML\UIParent.lua:784
9/20 00:55:36.785      PartyMemberFrame1:SetAttribute()
9/20 00:55:36.785      Interface\FrameXML\UnitFrame.lua:77 UnitFrame_SetUnit()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:44 PartyMemberFrame_ToPlayerArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:27 PartyMemberFrame_UpdateArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:335 PartyMemberFrame_OnEvent()
9/20 00:55:36.785      *:OnEvent:1 PartyMemberFrame1:OnEvent()
9/20 00:55:36.785      Interface\FrameXML\UnitFrame.lua:483
9/20 00:55:36.785  Execution tainted by Prat-3.0 while reading INTERFACE_ACTION_BLOCKED_SHOWN - Interface\FrameXML\UIParent.lua:781
9/20 00:55:36.785      PartyMemberFrame1PetFrame:SetAttribute()
9/20 00:55:36.785      Interface\FrameXML\UnitFrame.lua:77 UnitFrame_SetUnit()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:45 PartyMemberFrame_ToPlayerArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:27 PartyMemberFrame_UpdateArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:335 PartyMemberFrame_OnEvent()
9/20 00:55:36.785      *:OnEvent:1 PartyMemberFrame1:OnEvent()
9/20 00:55:36.785      Interface\FrameXML\UnitFrame.lua:483
9/20 00:55:36.785  An action was blocked in combat because of taint from Prat-3.0 - PartyMemberFrame1PetFrame:SetAttribute()
9/20 00:55:36.785      Interface\FrameXML\UnitFrame.lua:77 UnitFrame_SetUnit()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:45 PartyMemberFrame_ToPlayerArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:27 PartyMemberFrame_UpdateArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:335 PartyMemberFrame_OnEvent()
9/20 00:55:36.785      *:OnEvent:1 PartyMemberFrame1:OnEvent()
9/20 00:55:36.785      Interface\FrameXML\UnitFrame.lua:483
9/20 00:55:36.785  Global variable INTERFACE_ACTION_BLOCKED_SHOWN tainted by Prat-3.0 - Interface\FrameXML\UIParent.lua:784
9/20 00:55:36.785      PartyMemberFrame1:ôÞ()
9/20 00:55:36.785      Interface\FrameXML\UnitFrame.lua:77 UnitFrame_SetUnit()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:44 PartyMemberFrame_ToPlayerArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:27 PartyMemberFrame_UpdateArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:335 PartyMemberFrame_OnEvent()
9/20 00:55:36.785      *:OnEvent:1 PartyMemberFrame1:ôÞ()
9/20 00:55:36.785      Interface\FrameXML\UnitFrame.lua:483
9/20 00:55:36.785  Execution tainted by Prat-3.0 while reading INTERFACE_ACTION_BLOCKED_SHOWN - Interface\FrameXML\UIParent.lua:781
9/20 00:55:36.785      PartyMemberFrame1:Show()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:121 PartyMemberFrame_UpdateMember()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:46 PartyMemberFrame_ToPlayerArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:27 PartyMemberFrame_UpdateArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:335 PartyMemberFrame_OnEvent()
9/20 00:55:36.785      *:OnEvent:1 PartyMemberFrame1:OnEvent()
9/20 00:55:36.785      Interface\FrameXML\UnitFrame.lua:483
9/20 00:55:36.785  An action was blocked in combat because of taint from Prat-3.0 - PartyMemberFrame1:Show()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:121 PartyMemberFrame_UpdateMember()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:46 PartyMemberFrame_ToPlayerArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:27 PartyMemberFrame_UpdateArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:335 PartyMemberFrame_OnEvent()
9/20 00:55:36.785      *:OnEvent:1 PartyMemberFrame1:OnEvent()
9/20 00:55:36.785      Interface\FrameXML\UnitFrame.lua:483
9/20 00:55:36.785  Global variable INTERFACE_ACTION_BLOCKED_SHOWN tainted by Prat-3.0 - Interface\FrameXML\UIParent.lua:784
9/20 00:55:36.785      PartyMemberFrame1:PartyMemberFrame1:()
9/20 00:55:36.785      Interface\FrameXML\UnitFrame.lua:77 UnitFrame_SetUnit()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:44 PartyMemberFrame_ToPlayerArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:27 PartyMemberFrame_UpdateArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:335 PartyMemberFrame_OnEvent()
9/20 00:55:36.785      *:OnEvent:1 PartyMemberFrame1:PartyMemberFrame1:()
9/20 00:55:36.785      Interface\FrameXML\UnitFrame.lua:483
9/20 00:55:36.785  Execution tainted by Prat-3.0 while reading INTERFACE_ACTION_BLOCKED_SHOWN - Interface\FrameXML\UIParent.lua:781
9/20 00:55:36.785      PartyMemberFrame1PetFrame:Hide()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:159 PartyMemberFrame_UpdatePet()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:137 PartyMemberFrame_UpdateMember()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:46 PartyMemberFrame_ToPlayerArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:27 PartyMemberFrame_UpdateArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:335 PartyMemberFrame_OnEvent()
9/20 00:55:36.785      *:OnEvent:1 PartyMemberFrame1:OnEvent()
9/20 00:55:36.785      Interface\FrameXML\UnitFrame.lua:483
9/20 00:55:36.785  An action was blocked in combat because of taint from Prat-3.0 - PartyMemberFrame1PetFrame:Hide()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:159 PartyMemberFrame_UpdatePet()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:137 PartyMemberFrame_UpdateMember()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:46 PartyMemberFrame_ToPlayerArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:27 PartyMemberFrame_UpdateArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:335 PartyMemberFrame_OnEvent()
9/20 00:55:36.785      *:OnEvent:1 PartyMemberFrame1:OnEvent()
9/20 00:55:36.785      Interface\FrameXML\UnitFrame.lua:483
9/20 00:55:36.785  Global variable INTERFACE_ACTION_BLOCKED_SHOWN tainted by Prat-3.0 - Interface\FrameXML\UIParent.lua:784
9/20 00:55:36.785      PartyMemberFrame1:()
9/20 00:55:36.785      Interface\FrameXML\UnitFrame.lua:77 UnitFrame_SetUnit()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:44 PartyMemberFrame_ToPlayerArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:27 PartyMemberFrame_UpdateArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:335 PartyMemberFrame_OnEvent()
9/20 00:55:36.785      *:OnEvent:1 PartyMemberFrame1:()
9/20 00:55:36.785      Interface\FrameXML\UnitFrame.lua:483
9/20 00:55:36.785  Execution tainted by Prat-3.0 while reading INTERFACE_ACTION_BLOCKED_SHOWN - Interface\FrameXML\UIParent.lua:781
9/20 00:55:36.785      PartyMemberFrame1PetFrame:SetPoint()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:160 PartyMemberFrame_UpdatePet()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:137 PartyMemberFrame_UpdateMember()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:46 PartyMemberFrame_ToPlayerArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:27 PartyMemberFrame_UpdateArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:335 PartyMemberFrame_OnEvent()
9/20 00:55:36.785      *:OnEvent:1 PartyMemberFrame1:OnEvent()
9/20 00:55:36.785      Interface\FrameXML\UnitFrame.lua:483
9/20 00:55:36.785  An action was blocked in combat because of taint from Prat-3.0 - PartyMemberFrame1PetFrame:SetPoint()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:160 PartyMemberFrame_UpdatePet()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:137 PartyMemberFrame_UpdateMember()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:46 PartyMemberFrame_ToPlayerArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:27 PartyMemberFrame_UpdateArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:335 PartyMemberFrame_OnEvent()
9/20 00:55:36.785      *:OnEvent:1 PartyMemberFrame1:OnEvent()
9/20 00:55:36.785      Interface\FrameXML\UnitFrame.lua:483
9/20 00:55:36.785  Global variable INTERFACE_ACTION_BLOCKED_SHOWN tainted by Prat-3.0 - Interface\FrameXML\UIParent.lua:784
9/20 00:55:36.785      PartyMemberFrame1:8ÍGäÞ()
9/20 00:55:36.785      Interface\FrameXML\UnitFrame.lua:77 UnitFrame_SetUnit()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:44 PartyMemberFrame_ToPlayerArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:27 PartyMemberFrame_UpdateArt()
9/20 00:55:36.785      Interface\FrameXML\PartyMemberFrame.lua:335 PartyMemberFrame_OnEvent()
9/20 00:55:36.785      *:OnEvent:1 PartyMemberFrame1:8ÍGäÞ()
9/20 00:55:36.785      Interface\FrameXML\UnitFrame.lua:483

Please provide any additional information below.

The taint seems to be caused by one of the following:

Interface\AddOns\Prat-3.0\addon\addon.lua:30

Prat = select(2, ...)

(This is the addontable, the Prat.loading in Timestamps.lua:512 seems to point here, is this the source of the taint reading the addontable somehow?)

Interface\AddOns\Prat-3.0\addon\addon.lua:705

self.hooks[frame].AddMessage(frame, text, r, g, b, id, ...)

(this line AddMessage just points to the error referred to on Timestamps.lua:512

Interface\AddOns\Prat-3.0\modules\Timestamps.lua:512

if self.db.profile.show and self.db.profile.show[frame:GetName()] and not Prat.loading then

User When Change
pompachomp Jan 11, 2014 at 07:27 UTC Changed status from New to Invalid
stassart Sep 20, 2011 at 08:47 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 2 comments
  • Avatar of nyyr nyyr Oct 31, 2011 at 23:55 UTC - 0 likes

    I have a similar taint:

    10/31 22:19:46.309  Global variable Prat tainted by Prat-3.0 - Interface\AddOns\Prat-3.0\addon\addon.lua:30
    10/31 22:19:46.309  Execution tainted by Prat-3.0 while reading Prat - Interface\AddOns\Prat-3.0\modules\Timestamps.lua:512
    10/31 22:19:46.309      Interface\AddOns\Prat-3.0\addon\addon.lua:703
    10/31 22:19:46.309      Interface\FrameXML\UIParent.lua:783
    10/31 22:19:46.309      SearchLFGLeave()
    10/31 22:19:46.309      Interface\FrameXML\LFRFrame.lua:393 LFRBrowseFrame_OnUpdateAlways()
    10/31 22:19:46.309      UIParent:OnUpdate()
    10/31 22:19:46.309  An action was blocked because of taint from Prat-3.0 - SearchLFGLeave()
    10/31 22:19:46.309      Interface\FrameXML\LFRFrame.lua:393 LFRBrowseFrame_OnUpdateAlways()
    10/31 22:19:46.309      UIParent:OnUpdate()
    

    In the chat it says "Interface action failed because of an addon." If this occurs, I cannot use ground raid-markers anymore (if clicking them, a dialog appears saying that some random addon prevented the action).

    Btw: I disabled the high-cpu usage modules.

  • Avatar of stassart stassart Sep 21, 2011 at 21:28 UTC - 0 likes

    To be clear, complaining about the taintlog isn't just nit-picking. This is likely the cause of this addon sometimes being responsible for not being able to change glyphs or set raid markers (the ones on the ground) without doing a /reloadui.

  • 2 comments

Facts

Last updated
Jan 11, 2014
Reported
Sep 20, 2011
Status
Invalid - This was not a valid report.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
1

Reported by

Possible assignees