Prat 3.0

452 - CustomFilters not working in some channels

What steps will reproduce the problem?
1. Try to create a basic one letter filter, like "e".
2. Enable all the search channels for testing purpose.
3. Do "things" that will send text to the channels you want to test.

For example, the whisper chan IS monitored by custom filters : if somebody send me anything with a "e" in it it will highlight it or whatever you've set CustomFilters to do, but some other channels are not monitored. I couldn't test all of the channels, but I know that these channels don't work :

- Creature Emote / Creature Whisper / Creature Say / Creature Yell
- Item Loot / Money Loot
- Emote

With the same "e" filter as above, everything that has a "e" in it in these channels IS NOT recognized by CustomFilters.

Every channel that have a particular syntax doesn't seem to be recognized by CustomFilters.

I'm using the last version of Prat at the time I'm writing this : r672.

*IMPORTANT* -> Can you reproduce the problem when ONLY Prat is running ? Yes.

I play on EU, english language.

Do you have an error log of what happened? No.

User When Change
sylvanaar Oct 19, 2010 at 12:37 UTC Changed component from None to Specific Module
sylvanaar Oct 18, 2010 at 09:09 UTC Changed status from New to Accepted

Changed priority from Medium to Low

Changed milestone from None to Wish List
amasokin Oct 17, 2010 at 13:00 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 3 comments
  • Avatar of sylvanaar sylvanaar Oct 19, 2010 at 12:19 UTC - 0 likes

    I will fix it eventually.

  • Avatar of amasokin amasokin Oct 19, 2010 at 01:12 UTC - 0 likes

    Okay, thanks for the answer, hope you'll be able to fix it.

    And kudos for all of your amazing addons :)

  • Avatar of sylvanaar sylvanaar Oct 18, 2010 at 09:09 UTC - 0 likes

    This is due to the the recent change which fixed Prat processing all events by default. This in turn turned off some events. Ideally they should be reenabled under certain cases

  • 3 comments

Facts

Last updated
Oct 19, 2010
Reported
Oct 17, 2010
Status
Accepted - Problem reproduced / Need acknowledged.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Low - Might slip to a later milestone.
Votes
0
Component
Specific Module
Milestone
Wish List

Reported by

Possible assignees