Prat 3.0

166 - Substitution for Target Health Percent doesn't work

What steps will reproduce the problem?
1. Make a macro to announce the target health percent (/s %thp).
2. Target yourself.
3. Press your macro.
4. Instead of 100% or whatever your percent health is, you see 14005p or whatever your current HP is, with p on the end.

What is the expected output? What do you see instead?
I expect to see the target's health output like so: 100%.  Instead, I see 14005p.  This used to work before I updated.  I don't know which version broke it, or which was the last version that had the proper functionality.  I'll try to roll back and see what changed.  I do read the changelog each time though, and I don't think that anything changed in any version I've recently installed that would indicate this problem I'm having.

What version of the product are you using?

*IMPORTANT* -> Can you reproduce the problem when ONLY Prat is running?
I think so, I started to test last night but got interrupted by a sick kid, and now the servers are down.  I can tell you that I tried it with only a handful of addons, none chat mods to my knowledge, and it was still happening.  When the servers are up I can finish my testing and give you more information.

Do you play on US or EU. What language do you use?
US - English.

Do you have an error log of what happened?
No error is generated.

Please provide any additional information below.

User When Change
sylvanaar Oct 23, 2009 at 04:21 UTC Changed status from Accepted to Fixed
sylvanaar Oct 21, 2009 at 13:35 UTC Changed status from New to Accepted
xtoq Oct 20, 2009 at 15:58 UTC Changed name from Substitutions for Target Health Percent doesn't work to Substitution for Target Health Percent doesn't work
xtoq Oct 20, 2009 at 15:57 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 5 comments
  • Avatar of sylvanaar sylvanaar Oct 23, 2009 at 04:24 UTC - 0 likes

    Revision: 390
    Author: sylvanaar
    Date: 8:55:52 PM, Thursday, October 22, 2009
    Message:
    make %thp work
    ----
    Modified : /trunk/modules/Substitutions.lua

  • Avatar of xtoq xtoq Oct 22, 2009 at 23:42 UTC - 0 likes

    No, the newest version didn't fix it I'm afraid, and I ran it on a clean install with only Prat running. Still returns the same value.

  • Avatar of sylvanaar sylvanaar Oct 22, 2009 at 00:13 UTC - 0 likes

    Try the latest version

  • Avatar of xtoq xtoq Oct 21, 2009 at 21:29 UTC - 0 likes

    Well it used to work, and I can confirm its does happen with only Prat running. But I'm not sure what version it stopped working with. I can tell you it was recently, and its surely a beta version. I'll roll back to the last actual release and see if it was still working then. The only reason I even know about it tbh is that I have a macro that I use in raids to announce the percentage of the boss's health - and only the percentage, not the HP - to keep vent clear. Its nice and easy, but like I said, a few updates ago it started acting like this.

    I'll roll back later tonight and let you know if the last release version worked, so you at least know if it was something in a beta that broke. Sorry for my poor troubleshooting, I know its hard to go on such limited information.

  • Avatar of sylvanaar sylvanaar Oct 21, 2009 at 13:37 UTC - 0 likes

    I suppose it is caused by the order that the substitutions are expanded in %th and %thp - if %th goes first, then you get <target health>p

  • 5 comments

Facts

Last updated
Oct 23, 2009
Reported
Oct 20, 2009
Status
Fixed - Developer made requested changes. QA should verify.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees