Postal

112 - Lua errors

What steps will reproduce the problem?

1. sending ingame mails or adding friends in the Social window

What is the expected output? What do you see instead?

Lua error , but still works

What version of the product are you using?

latest Release version , 3.5.1

Do you have an error log of what happened?

8x FrameXML\AutoComplete.lua:227 attempt to index field "?" (a nil value)
FrameXML\AutoComplete.lua:227 in function "AutoComplete_UpdateResults"
FrameXML\AutoComplete.lua:185 in function "AutoComplete_Update"
Postal-v3.5.1\Modules\BlackBook.lua:203 in function <Postal\Modules\BlackBook.lua:201
(tail call): ?
FrameXML\AutoComplete.lua:317 in function "AutoCompleteEditBox_OnTextChanged"
FrameXML\StaticPopup.lua:3800 in function "StaticPopup_EditBoxOnTextChanged"
<string>:"*:OnTextChanged":1: in function <string>:"*:OnTextChanged":1

Locals:
parent = StaticPopup1EditBox {
 0 = <userdata>
 autoCompleteParams = <table> {
 }
 addHighlightedText = true
}
text = "s"
cursorPosition = 1
self = AutoCompleteBox {
 0 = <userdata>
 attachPoint = "BELOW"
 parent = StaticPopup1EditBox {
 }
 selectedIndex = 0
 maxHeight = 69.999942779541
}
attachPoint = "BELOW"
realmStart = nil

User When Change
reaper666735 Jan 11, 2014 at 18:07 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

Facts

Reported
Jan 11, 2014
Status
New - Issue has not had initial review yet.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees