PitBull Unit Frames 4.0

1055 - Error: invalid fontHeight: 0?

What steps will reproduce the problem?
1.log in
2.
3.

What is the expected output? What do you see instead?
Name/class/power texts aren't showing up, but after /reload it's all fine.

What version of the product are you using?
beta47

Do you have an error log of what happened?
4x PitBull4_LuaTexts:player:Lua:PVPTimer caused the following error when calling SetFont(Addons\SharedMedia\fonts\Emblem.ttf,0,nil):
PitBull4\Controls\Controls.lua:108 ERROR: PitBull4_FontString_4:SetFont(): invalid fontHeight: 0, height must be > 0
PitBull4_LuaTexts-v4.0.0-beta47-11-g519c516\LuaTexts.lua:843 in function <PitBull4_LuaTexts\LuaTexts.lua:838
PitBull4_LuaTexts-v4.0.0-beta47-11-g519c516\LuaTexts.lua:902 in function <PitBull4_LuaTexts\LuaTexts.lua:856
PitBull4_LuaTexts-v4.0.0-beta47-11-g519c516\LuaTexts.lua:1445 in function "AddFontString"
PitBull4-v4.0.0-beta47-11-g519c516\ModuleHandling\TextProviderModule.lua:118 in function "UpdateFrame"
PitBull4-v4.0.0-beta47-11-g519c516\ModuleHandling\Module.lua:319 in function "Update"
PitBull4-v4.0.0-beta47-11-g519c516\UnitFrame.lua:808 in function "Update"
PitBull4-v4.0.0-beta47-11-g519c516\UnitFrame.lua:728 in function "RecheckConfigMode"
PitBull4-v4.0.0-beta47-11-g519c516\Options\ConfigMode.lua:58 in function "RecheckConfigMode"
PitBull4-v4.0.0-beta47-11-g519c516\Main.lua:1351 in function "OnProfileChanged"
PitBull4-v4.0.0-beta47-11-g519c516\Main.lua:1416 in function <PitBull4\Main.lua:1386
(tail call): ?
<in C code>
<string>:"safecall Dispatcher[1]":9: in function <string>:"safecall Dispatcher[1]":5
(tail call): ?
...\DataStore\libs\AceAddon-3.0\AceAddon-3.0-12.lua:558 in function "EnableAddon"
...\DataStore\libs\AceAddon-3.0\AceAddon-3.0-12.lua:651 in function <...\DataStore\libs\AceAddon-3.0\AceAddon-3.0.lua:636
<in C code>
FrameXML\UIParent.lua:303 in function "UIParentLoadAddOn"
FrameXML\UIParent.lua:377 in function "TimeManager_LoadUI"
FrameXML\UIParent.lua:737 in function <FrameXML\UIParent.lua:702

Locals:
nil
--------------------------------------------------------------------------------------------------------
5x PitBull4_LuaTexts:player:Lua:Name caused the following error when calling SetFont(Addons\SharedMedia\fonts\Emblem.ttf,0,nil):
PitBull4\Controls\Controls.lua:108 ERROR: PitBull4_FontString_2:SetFont(): invalid fontHeight: 0, height must be > 0
PitBull4_LuaTexts-v4.0.0-beta47-11-g519c516\LuaTexts.lua:843 in function <PitBull4_LuaTexts\LuaTexts.lua:838
PitBull4_LuaTexts-v4.0.0-beta47-11-g519c516\LuaTexts.lua:902 in function <PitBull4_LuaTexts\LuaTexts.lua:856
PitBull4_LuaTexts-v4.0.0-beta47-11-g519c516\LuaTexts.lua:1445 in function "AddFontString"
PitBull4-v4.0.0-beta47-11-g519c516\ModuleHandling\TextProviderModule.lua:118 in function "UpdateFrame"
PitBull4-v4.0.0-beta47-11-g519c516\ModuleHandling\Module.lua:319 in function "Update"
PitBull4-v4.0.0-beta47-11-g519c516\UnitFrame.lua:808 in function "Update"
PitBull4-v4.0.0-beta47-11-g519c516\UnitFrame.lua:728 in function "RecheckConfigMode"
PitBull4-v4.0.0-beta47-11-g519c516\Options\ConfigMode.lua:58 in function "RecheckConfigMode"
PitBull4-v4.0.0-beta47-11-g519c516\Main.lua:1351 in function "OnProfileChanged"
PitBull4-v4.0.0-beta47-11-g519c516\Main.lua:1416 in function <PitBull4\Main.lua:1386
(tail call): ?
<in C code>
<string>:"safecall Dispatcher[1]":9: in function <string>:"safecall Dispatcher[1]":5
(tail call): ?
...\DataStore\libs\AceAddon-3.0\AceAddon-3.0-12.lua:558 in function "EnableAddon"
...\DataStore\libs\AceAddon-3.0\AceAddon-3.0-12.lua:651 in function <...\DataStore\libs\AceAddon-3.0\AceAddon-3.0.lua:636
<in C code>
FrameXML\UIParent.lua:303 in function "UIParentLoadAddOn"
FrameXML\UIParent.lua:377 in function "TimeManager_LoadUI"
FrameXML\UIParent.lua:737 in function <FrameXML\UIParent.lua:702

Locals:
nil

Please provide any additional information below.

User When Change
Shefki Sep 30, 2013 at 03:57 UTC Changed status from New to Duplicate
ahua Sep 26, 2013 at 16:32 UTC

Deleted attachment PitBull4.lua: I uploaded same file to my comment.

ahua Sep 26, 2013 at 16:10 UTC

Added attachment PitBull4.lua

ahua Sep 25, 2013 at 17:15 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 3 comments
  • Avatar of Shefki Shefki Sep 30, 2013 at 03:57 UTC - 0 likes

    This is indeed a duplicate of 1050. The problem with the font size is just a different side effect resulting from the workarounds I'd already applied that weren't quiet complete.

    However, thank you very much for your report since this ultimately allowed me to duplicate the problem. The font was coming from Prat and that triggered the race condition on my machine that I hadn't been able to reproduce so far.

  • Avatar of ahua ahua Sep 26, 2013 at 16:25 UTC - 0 likes

    @Shefki: Go

    How to reproduce these errors.
    Install Pitbull4 beta47-11 and SharedMedia r184.
    Go to Pitbull options > Layout Editor > Texts, and change Default font to "Enigmatic".
    Exit WoW then start WoW.

    Last edited Sep 26, 2013 by ahua
    Name Description Size MD5
    PitBull4.lua after clean install 10.9 KiB a50766b9e122...
  • Avatar of Shefki Shefki Sep 26, 2013 at 02:09 UTC - 0 likes

    This is probably related to ticket 1050, however can you provide your configuration file and specify which profile you're using to get this error. I'm interesting in debugging how the font size gets calculated as negative or 0 values. You can find your config file at: WTF/Account/$ACCOUNTID/SavedVariables/PitBull4.lua

  • 3 comments

Facts

Last updated
Sep 30, 2013
Reported
Sep 25, 2013
Status
Duplicate - This report duplicates an existing ticket.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees