PitBull Unit Frames 4.0

v4.0.0-beta43-23-gb0aa1d5

Change log

Shefki:
    - Remove pre-5.1 compatibility from Aura Filters.
    - Remove pre 5.1 support from Chi module.
    - Remove pre-mop compatibility from UnitFrame.lua
    Conflicts:
    
        UnitFrame.lua
    - Remove pre-mop compatibility in ThreatBar module.
    - Remove support for old guid format.
    - Remove check for MoP from ShadowOrbs module.
    - Remove pre-mop compatibility from ReadyCheckIcon module.
    - Remove pre-mop compatibility from RangeFader module.
    - Remove pre-mop compatibility from RaidTargetIcon module.
    - Remove pre-mop compatibility from MasterLooterIcon module.
    - Remove pre-mop compatibility from the LuaTexts script environment.
    - Remove pre-mop compatibility from LuaTexts module.
    - Remove pre-mop compatibility from LeaderIcon module.
    - Remove pre-mop compatability from HolyPower module.
    - Remove pre-mop compatability from HealthBar module.
    - Remove pre-mop support from Main.lua
    - Remove pre-mop support from Eclipse module.
    - Remove pre-mop support for raid/party events from HideBlizzard module.
    - Remove pre-mop code to support ranged slot.
    - Enable Totems module for Mages with Rune of Power.
    - Remove pre-MOP compat from Totem module.
    - Just stop using MAX_ARENA_TEAM_MEMBERS entirely, it wasn't really the right constant anyway.
    - Switch to using the new 5.2 based popup menu system.  This will allow the SetFocus/ClearFocus, Dismiss etc...  However, this also does remove the feature to add Ready and Role Check menus for group leaders.

Facts

Uploaded on
Mar 10, 2013
Game version
  • 5.2.0
Filename
PitBull4-v4.0.0-beta43-23-gb0aa1d5.zip
Size
918.1 KiB
MD5
d7a332161f9d35a668a7246727da0e39
Type
Alpha
Status
Normal
Downloads
312

Authors