oUF_Adirelle

15 - Mysterious frame positioning problem

What steps will reproduce the problem?

1. More the frames to where you want them initially in a single (default) layout via the built-in unlock/lock anchors (courtesy of LibMovable-1.0).

2. Relog. Join a LFD 5-man party. After completing the dungeon, leave the party.

What is the expected output? What do you see instead?

Expected: no problems.

Instead: immediately after leaving the party, the player frame suddenly, weirdly moves on its own to a position far away from where you originally locked it. In this example, its original locked location was in the upper left of the UI about 1 inch from the top. It moved on its own to the bottom left-center of the UI.

Furthermore, bringing up the oUF_Adirelle options to unlock the frames to reposition the mysterious moved one, it fails to function (the frame anchors do not show up). Repositioning the frames via the option button doesn't work either.

Relog and the mispositioned player frame mysteriously goes back to its originally locked position in the upper left of the UI. As well, the unlock option to bring up the anchors works once again.

What version of the product are you using?

v1.8.1 with oUF comitt 5e378d423f99282cbfc7.

Do you have an error log of what happened?

No errors.

Please provide any additional information below.

No taint occurred during the session when that happened. Have never experienced this behavior before with any other oUF layout in combination with oUF_MovableFrames when in a party. That addon was not on at the same time with oUF_Adirelle when the above problem occurred.

User When Change
Zidomo Aug 16, 2011 at 17:16 UTC Changed description:
  Expected: no problems.

- Instead: the player frame suddenly, weirdly moves on its own to a position far away from where you originally locked it. In this example, its original locked location was in the upper left of the UI about 1 inch from the top. It moved on its own to the bottom left-center of the UI.
+ Instead: immediately after leaving the party, the player frame suddenly, weirdly moves on its own to a position far away from where you originally locked it. In this example, its original locked location was in the upper left of the UI about 1 inch from the top. It moved on its own to the bottom left-center of the UI.
- Furthermore, bring up the oUF_Adirelle options to unlock the frames to reposition the mysterious mover, it fails to function (the frame anchors do not show up). Repositioning the frames via the option button doesn't work either.
+ Furthermore, bringing up the oUF_Adirelle options to unlock the frames to reposition the mysterious moved one, it fails to function (the frame anchors do not show up). Repositioning the frames via the option button doesn't work either.
  Relog and the mispositioned player frame mysteriously goes back to its originally locked position in the upper left of the UI. As well, the unlock option to bring up the anchors works once again.
Zidomo Aug 16, 2011 at 17:14 UTC Changed description type from Plain Text to WikiCreole

Changed description:
  What steps will reproduce the problem?

- 1. More the frames to where you want them initially in a single (default) using the built-in LibMovable-1.0.
+ 1. More the frames to where you want them initially in a single (default) layout via the built-in unlock/lock anchors (courtesy of LibMovable-1.0).
  2. Relog. Join a LFD 5-man party. After completing the dungeon, leave the party.
----------------------------------------
  Please provide any additional information below.

- No taint occurred during the session when that happened. Have never experienced this behavior before with any oUF layout have run when in a party.
+ No taint occurred during the session when that happened. Have never experienced this behavior before with any other oUF layout in combination with [[http://www.wowinterface.com/downloads/info15425-oUFMovableFrames.html|oUF_MovableFrames]] when in a party. That addon was not on at the same time with oUF_Adirelle when the above problem occurred.
Zidomo Aug 16, 2011 at 09:28 UTC Changed description:
  Instead: the player frame suddenly, weirdly moves on its own to a position far away from where you originally locked it. In this example, its original locked location was in the upper left of the UI about 1 inch from the top. It moved on its own to the bottom left-center of the UI.

- Furthermore, bring up the oUF_Adirelle options to unlock the frames to reposition the mysterious mover, it fails to function (the frame outlines do not show up). Repositioning the frames via the option button doesn't work either.
+ Furthermore, bring up the oUF_Adirelle options to unlock the frames to reposition the mysterious mover, it fails to function (the frame anchors do not show up). Repositioning the frames via the option button doesn't work either.
- Relog and the mispositioned player frame mysteriously goes back to its originally locked position in the upper left of the UI.
+ Relog and the mispositioned player frame mysteriously goes back to its originally locked position in the upper left of the UI. As well, the unlock option to bring up the anchors works once again.
  What version of the product are you using?
Zidomo Aug 16, 2011 at 09:27 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 4 comments
  • Avatar of Zidomo Zidomo Aug 20, 2011 at 11:46 UTC - 0 likes

    Nope, it still happens on a character after setting a custom profile (and relogging, etc.). A gigantic pain.

  • Avatar of Zidomo Zidomo Aug 19, 2011 at 16:21 UTC - 0 likes

    More research: its only a problem when you are using the "Default" profile instead of selecting a specific one for each character. Which is quite a hassle. Selecting a profile other than the "Default" one - - one of the pre-made "character name-server name", "character class" or one of your own - - the improper repositioning on hearthing does not happen.

    The exact same issue occurs with one of the few other layouts that has its own repositioning code (& uses Ace3) instead of using oUF_MovableFrames: oUF_Henna.

    As using a default profile is something commonly done and it doesn't cause an issue when using a layout with oUF_MovableFrames, might be worth it to embed & use that instead. Or if keeping LibMovable-1.0, hope the issue can be fixed.

    Last edited Aug 19, 2011 by Zidomo
  • Avatar of Zidomo Zidomo Aug 17, 2011 at 03:39 UTC - 0 likes

    Just happened two times again, this time in two different raids on different characters (using the same profile). Same location the player frame moved to in the ticket and the same inability to click the "Unlock" button to move it back to the proper position...until after a relog.

    This time however, confirmed it occurs not when you leave the party/raid, but when you hearth back/are transported back to your hearth point (after a raid, party, etc.).

    Hope it can be fixed.

  • Avatar of Zidomo Zidomo Aug 16, 2011 at 17:17 UTC - 0 likes

    Edits done that should have been done before the ticket was first filed...heh.

  • 4 comments

Facts

Last updated
Mar 30, 2012
Reported
Aug 16, 2011
Status
New - Issue has not had initial review yet.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
1

Reported by

Possible assignees