oRA3

138 - Ready Check window disappearing occasionally

Starting in the last week or so with the new alphas, I've been noticing a bug that only happens every now and then (maybe 1 out of 10 ready checks?):aAfter performing a ready check (while being the raid leader), the oRA3 ready check window will pop up momentarily then disappear a fraction of a second later, long before everyone has finished responding or combat has started.

User When Change
funkydude Sep 18, 2013 at 10:34 UTC
funkydude Jun 03, 2013 at 19:03 UTC
funkydude Jun 02, 2013 at 15:03 UTC
ywfn May 28, 2013 at 04:13 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of funkydude funkydude Sep 18, 2013 at 10:33 UTC - 0 likes

    Yeah, I'll just close this, and hopefully not re-open it again 1 day later :p

  • Avatar of ywfn ywfn Sep 18, 2013 at 10:31 UTC - 0 likes

    i think this problem is fully fixed now, i haven't seen it in over a month and that includes a lot of progression this week and last.

  • Avatar of ywfn ywfn Aug 15, 2013 at 05:36 UTC - 0 likes

    With my own temp fix in place, the problem never happened during this week's raiding. Since things are on farm atm, though, we aren't doing many pulls per week...will need a lot more testing.

  • Avatar of nebula169 nebula169 Aug 14, 2013 at 22:16 UTC - 0 likes

    that would make sense, I added stopping the fader in the OnShow and stopping animations as well as unregistering GROUP_ROSTER_UPDATE in an OnHide to make sure everything is nice and tidy when the frame hides

  • Avatar of ywfn ywfn Aug 12, 2013 at 10:48 UTC - 0 likes

    I found one source of this problem. Not yet sure if it accounts for all occurrences or not...

    What I noticed was happening is that when I've been tabbed out for a while, and tab back in, if a previous ready check was still up, and I hit a new ready check right away (before the animation thing fully finishes closing the previous one), then the new ready check window disappears right away. As you can imagine, during raids this isn't too uncommon of an activity, ie: tab out while someone's AFK during a ready check, then later tab back in and do a new ready check immediately.

    Was able to fix it by changing the start of createWindow() so that if frame already exists, it calls a Stop() on its animFader, before returning.

  • Avatar of nebula169 nebula169 Jun 10, 2013 at 12:42 UTC - 0 likes

    I suppose I can just change it back to updating the window title on a one second loop with the duration set off the value in the READY_CHECK event. using the game's api is suppose to make things work nicely D;

  • Avatar of ywfn ywfn Jun 10, 2013 at 02:55 UTC - 0 likes

    just saw it happen again I believe.

    definitely pretty rare compared to before, maybe the new timer just needs to be longer?

    Last edited Jun 10, 2013 by ywfn
  • Avatar of funkydude funkydude Jun 09, 2013 at 12:45 UTC - 0 likes

    Lol... no, this was my main PC, and only seen it once.

  • Avatar of nebula169 nebula169 Jun 09, 2013 at 10:39 UTC - 0 likes

    I added a second delay before checking the timer, so something must have been really fucked up when it happened to you, funkeh ;[ sure you were updated/not on your gf's terrible laptop? >.>

  • Avatar of ywfn ywfn Jun 09, 2013 at 02:23 UTC - 0 likes

    haven't seen it here in about a week of raiding, since upgrading to r636+. definitely a lot less common now, at least.

Facts

Last updated
Sep 18, 2013
Reported
May 28, 2013
Status
Fixed - Developer made requested changes. QA should verify.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees