MrPlow

35 - Sorting problems with GB

What steps will reproduce the problem?

/mp gbank theworks

What is the expected output? What do you see instead?

I have among other things these in one of my GB tabs:

[Flask of Port], http://www.wowhead.com/item=2593

[Delicious Chocolate Cake], http://www.wowhead.com/item=33924

[Styleen's Sour Suckerpop], http://www.wowhead.com/item=18633

2 stacks of Port, 3 Delicious Chocolate and 1 Suckerpop. They rarely end up in the same order. Normally the port dont group together and same goes with the 3 stacks of Chocolate.

So usally it end up like this:

[Flask of Port]
[Delicious Chocolate Cake]
[Styleen's Sour Suckerpop]
[Flask of Port]
[Delicious Chocolate Cake]
[Delicious Chocolate Cake]

So the "TheWorks" doesnt get it all in the correct order.

Besides... the /mp gbank theworks isn't very fast but in these products they also move the items around many times so it takes extra time. I think all of this is the same problem just wanted to point it out.

What version of the product are you using?

v10.2.6.5-Beta and v10.2.6.6-Beta

Do you have an error log of what happened?

no

If MrPlow is looping endlessly over a few items follow the instructions below:

1. Take note of which items are being swapped. Be aware, that it will almost always involve at least 3 items at most times.
2. use  /mp add [Blocky Item of Block][Womble cabbage of Frog][Fried Green Tomatoes] (use shift-click on the items)
3. run /mp sort and copy/paste the resultant output to the ticket (after hitting /mp stop after it loops)
4. note /mp watching and /mp clear will show what's being monitored and clear the list respectively.

Please provide any additional information below.

I messed up the above information (and I didnt see it until I wrote all above). The items in the GB doesnt loop endlessly either.

I did this:
/mp add  [Flask of Port] [Delicious Chocolate Cake] [Styleen's Sour Suckerpop]

SHIFT+click on those 3 items, then I hit ENTER but I didnt get any respons on that.

Moving these 3 items and put them in my normal bags and do a "/mp theworks" seem to go just fine, I didnt try it too much so I might be wrong but at least it worked first time and no "looping" occurred either.

User When Change
in2it Jun 04, 2011 at 14:13 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

Facts

Reported
Jun 04, 2011
Status
New - Issue has not had initial review yet.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees