Masque

144 - Group:Delete() doesn't remove the group from the msq configuration

Hey again,

While playing a round more I found that after I deleted a group with Group:Delete() and opening MSQ that the group is still displayed in the configuration. I have to do a reload before the correct list is displayed again.

After I saw this, I checked the documentation on the :Delete() (http://www.wowace.com/addons/masque/pages/api/groups/#w-delete) and saw also that the documentation doesn't speak of any argument, but looking in the code you have the Static argument (I also use  :Delete(true)). Maybe the documentation is out of date?

User When Change
Beautiuz Feb 12, 2013 at 22:00 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 4 comments
  • Avatar of Beautiuz Beautiuz Feb 14, 2013 at 12:01 UTC - 0 likes

    For AuraFrames, when a container is deleted I release all the used buttons into a pool that can be used by other containers. When an other container gets a button from that pool I do a reskin of that button with the container config.

    So there is no need for getting them back into blizzard skin between containers for me. But yea, for most addons you want that.

  • Avatar of StormFX StormFX Feb 13, 2013 at 16:09 UTC - 0 likes

    That's because it was only meant to be utilized internally. It wouldn't make any sense for an add-on to NOT have the buttons reset after remove the group. ;)

  • Avatar of Beautiuz Beautiuz Feb 13, 2013 at 09:35 UTC - 0 likes

    I meant that I know what static does, but the documentation doesn't say anything about it.

  • Avatar of StormFX StormFX Feb 12, 2013 at 23:35 UTC - 0 likes

    The "Static" flag just tells decides whether or not the Blizzard skin is reapplied. I'll look into the other issue.

  • 4 comments

Facts

Reported
Feb 12, 2013
Status
New - Issue has not had initial review yet.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees