LibQuixote-2.0

14 - Memory leak ?

What steps will reproduce the problem?
1. Install lib or embed it
2. That's it

What is the expected output? What do you see instead?
Addon memory usage is going > 1mb, sometimes 2-3mb in capitals even if no addon has registered callbacks.
Used alone, there's no problem
I don't know if it's normal, because I saw a chat throttle lib embed, but it's clearly way to much for a quest scanning lib.

What version of the product are you using?
r92

Do you have an error log of what happened?
Nope

User When Change
ZergRael Nov 11, 2010 at 21:28 UTC Changed description:
  What is the expected output? What do you see instead?
  Addon memory usage is going > 1mb, sometimes 2-3mb in capitals even if no addon has registered callbacks.
+ Used alone, there's no problem
  I don't know if it's normal, because I saw a chat throttle lib embed, but it's clearly way to much for a quest scanning lib.

  What version of the product are you using?
ZergRael Nov 11, 2010 at 21:11 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 1 comment
  • Avatar of Dridzt Dridzt Jul 22, 2013 at 20:03 UTC - 0 likes

    This is still an issue with r102.

    It's hard to debug because this only happens on a cold login in my system.
    After a /reloadui it stops eating up memory like it's going out of style and forcing a gc every 5-10sec.

    But on a cold login I'm seeing rates of 1mb/sec until it goes to 10mb -> GC -> repeat.

  • 1 comment

Facts

Last updated
Jul 22, 2013
Reported
Nov 11, 2010
Status
New - Issue has not had initial review yet.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
2

Reported by

Possible assignees