LibMSP

This project has become inactive.

This project is inactive and its default file will likely not work with the most recent version of World of Warcraft. The author may have abandoned it, or it may have outlived its usefulness.

LibMSP is an extremely small public domain embeddable library that WoW RP addons can embed to make supporting the Mary Sue Protocol (MSP) very easy. It supports all the backend protocol internals, and lets you get on with the UI and frontend.

MyRolePlay is based on this library (from 4.0.6.72 onwards); any other AddOns that wish to be compatible are encouraged to use it as well, as it provides a convenient, well-tested, ready-made avenue for MSP support.

However, a user shouldn't load more than one MSP AddOn (whether LibMSP-based or otherwise) at a time, otherwise there could be a fight as to which AddOn gets to implement what, or which AddOn manages the flags.

LibMSP requires WoW 4.1 or later. Its only dependency is ChatThrottleLib (v22 or later), which has no other dependencies.

For more information about MSP please see http://moonshyne.org/msp/

You must login to post a comment. Don't have an account? Register to get one!

Facts

Date created
May 02, 2011
Categories
Last update
Jun 20, 2011
Development stage
Inactive
License
Public Domain
Curse link
LibMSP
Downloads
130
Recent file
  • R: v8 for 4.1 Jun 20, 2011

Authors

Relationships

Required dependency
ChatThrottleLib