LibMounts-1.0

READ THIS BEFORE COMMENTING

All mounts including Mist of Pandaria mounts have been added if they do not show up for you make sure you have the latest version of the lib

Library to aid in the classification of mounts. See http://www.wowace.com/addons/libmounts-1-0/pages/api/lib-mounts-1-0/lib-mounts-1-0/ for API info

Use http://www.wowace.com/addons/libmounts-1-0/pages/lib-mounts-1-0-manual-documented/ for API documentation till the documenter starts working again.

Why this Library?
Because Blizzard refuses give us any way to sort our mounts by their type (ground,air,water,speed,location). This lib remedies this problem and allows addon authors to easily categorize the mounts a character has.

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of Tymesink Tymesink Aug 25, 2012 at 20:12 UTC - 0 likes

    Will this library be updated for MoP?

  • Avatar of Stanzilla Stanzilla Jul 16, 2012 at 23:41 UTC - 0 likes

    LibMounts-1.0: Obsidian Nightwing was not found in the mount database. If this is a valid mount, please contact us at http://www.wowace.com/addons/libmounts-1-0/ to get this mount added ASAP

  • Avatar of yssaril yssaril Jan 01, 2012 at 18:27 UTC - 0 likes

    @BlackNet21: Go

    your using an old version

  • Avatar of BlackNet21 BlackNet21 Jan 01, 2012 at 16:18 UTC - 0 likes

    says Darkmoon Dancing Bear and Swift Forest Strider is not in the lib.

  • Avatar of yssaril yssaril Dec 06, 2011 at 16:30 UTC - 0 likes

    Oops forgot to tag but should be up in a minute

  • Avatar of KizEY KizEY Dec 06, 2011 at 16:18 UTC - 0 likes

    add to ground and fly:
        [107203] = true, --Tyriel's Charger

    Last edited Dec 06, 2011 by KizEY
  • Avatar of yssaril yssaril Sep 01, 2011 at 07:01 UTC - 0 likes

    @atroxus1: Go

    try updating your mount addon (or remove the lib from the addon and install the lib standalone)

    something on your end is not loading correctly

  • Avatar of atroxus1 atroxus1 Sep 01, 2011 at 06:06 UTC - 0 likes

    Until about a week ago I had no problems with the Flameward Hyppogryph or the sea turtle mounts. But suddenly I am getting an error "LibMounts-1.0: Flameward Hippogryph was not found in the mount database. If this is a valid mount, please contact us at http://www.wowace.com/addons/libmounts-1-0/ to get this mount added ASAP". I have since updated my addon. I have tried both the R and the A versions and if I look in the data.lua file I see both mounts listed there. I am still getting the same error when I log in though.

    Uninstalled libmounts and reinstalled. Error cleared and mount mod works for hippogryph now. Sea turtle still not working but I can deal with that.

    Last edited Sep 01, 2011 by atroxus1
  • Avatar of Jenkaia Jenkaia Jul 30, 2011 at 18:42 UTC - 0 likes

    Flameward Hyppogryph needs to be added. :)

  • Avatar of Allara Allara Jul 28, 2011 at 00:13 UTC - 0 likes

    I may be misunderstanding how this works, but it appears the Subdued Seahorse (98718) should not be in the Vashj'ir section. This mount is just like the Sea Turtle—it is usable in any water. I had to remove line 340 of Data.lua and also manually edit the Mounted saved variables to get this mount in the proper configuration.

Facts

Date created
Oct 11, 2010
Category
Last update
Nov 02, 2013
Development stage
Release
License
Customized BSD
Curse link
LibMounts-1.0
Downloads
16,828
Recent files
  • R: v1.2.10 for 5.4.1 Nov 02, 2013
  • A: r87 for 5.4.0 Nov 01, 2013
  • A: r86 for 5.4.0 Nov 01, 2013
  • A: r84 for 5.4.0 Nov 01, 2013
  • A: r83 for 5.4.0 Oct 23, 2013

Authors

Relationships

Embedded library
CallbackHandler-1.0
LibStub