LibDataBroker-1.1

You can find LDB’s primary repo and it’s documentation on GitHub If you have a patch, please fork on GitHub and commit there.

Note to addon authors

If you have a .pkgmeta

Do not use an embed entry for LDB if you allow no-lib packages, your no-lib versions will not include LDB in them. Instead you should hard-embed LDB in your addon and add a “tools used” entry for “libdatabroker-1-1”. Any files packaged after that will include the relationship. If you don’t want to repack, you can edit the existing files on wowace to add the relationship.

Vote for this ticket if you’d like Ace to fix the .pkgmeta issue so you don’t have to hard-embed.

If you don’t have a .pkgmeta

In this case, you can edit the “default relationships” on wowace’s project page, this will have the same effect as editing a .pkgmeta. This means you’ll have to update the files as well, or make new tags.

I also wrote a script to update relationships on my own addons. Feel free to use it (and tweak it).

Facts

Date created
Jul 21, 2009
Categories
Last update
Jul 22, 2009
Development stage
Mature
License
All Rights Reserved
Curse link
LibDataBroker-1.1
Reverse relationships
87
Downloads
17,058
Recent files
  • R: v1.1.4 for 3.2.0 Jul 22, 2009
  • R: v1.1.1 for 3.2.0 Jul 22, 2009

Authors