Inline Aura

280 - Macro Icons are Dimmed for Modded Spells

----- What steps will reproduce the problem?
Druids have Wild Charge, Skull Bash, and Faerie Fire spells which change depending on form.

On my action bars, if I place any of these abilities (by directly adding them from spell book)
And then create a simple macro:  /cast $ability  (with or without #showtooltip etc...)

The normal spell will display properly.
The macro spell will be dimmed/disabled in appearance.

----- What is the expected output? What do you see instead?
The macro should function like the normal spell.  This worked fine pre-5.0.

----- What version of the product are you using?
Latest (1.8.7)

----- Do you have an error log of what happened?

----- Please provide any additional information below.

  • macros.jpg
User When Change
adraffy Oct 02, 2012 at 09:21 UTC

Added attachment macros.jpg

adraffy Oct 02, 2012 at 09:20 UTC

Deleted attachment macros.jpg: forgot to target a mob

adraffy Oct 02, 2012 at 09:19 UTC

Added attachment macros.jpg

adraffy Oct 02, 2012 at 09:19 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 4 comments
  • Avatar of adraffy adraffy Oct 20, 2012 at 20:57 UTC - 0 likes

    I made a thread about this on the Druid forum to try attract developer attention: http://us.battle.net/wow/en/forum/topic/6934954312

    I also have a thread in the Bug Fixes forum: http://us.battle.net/wow/en/forum/topic/6893519976

  • Avatar of adraffy adraffy Oct 15, 2012 at 01:40 UTC - 0 likes

    This appears to be a Blizzard bug.

    Same thing happens when all addons are disabled.

  • Avatar of adraffy adraffy Oct 06, 2012 at 23:19 UTC - 0 likes

    This fixes it some what, there still seems to be an issue on log-in and reload ui (and possibly on zone-in).

    If I login/reload while in form, my fix does not solve the problem. If I am in caster form on login/reload, then my fix solves the problem.

  • Avatar of adraffy adraffy Oct 06, 2012 at 03:36 UTC - 0 likes

    I seem to be able to fix this bug by adding the following code to Core.lua:1440

    self:RegisterEvent('UPDATE_SHAPESHIFT_FORM', 'ACTIONBAR_UPDATE_STATE');
    
    Last edited Oct 06, 2012 by adraffy: formatting
  • 4 comments

Facts

Last updated
Oct 02, 2012
Reported
Oct 02, 2012
Status
New - Issue has not had initial review yet.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees