Grid

717 - 25-40 Man Raid Toggle Option.

Grid version:

Check the addon’s TOC file if you’re not sure!
5.4.1.1628

WoW version and region/language:

Check the WoW login screen if you’re not sure!
5.4.1

Character race, class, spec, and level:

Draenei Shaman, Restoration, 90.

Steps to reproduce the problem:

Be in a 25+ man raid. LFR, BGs and guild raids.

What you expected to happen:

Clean performance.

What actually happened:

A lot of lag.

Does the problem still happen when all other addons — including all Grid plugins — are disabled?

Yes

Does the problem still happen after you switch to a new profile in Grid with default settings, log out, and log back in?

If not, please attach your Grid saved variables file to your ticket, and TELL US WHICH PROFILE you were using when the problem happened.
Yes, I use a variation of the default with 100% width, center text 2, and status indicators for my Riptide, Earth Shield, Water Shield, Earthliving and other shaman buffs and healing related information. All unnecessary statuses are disabled even those that are, such as Incoming Heal.

Exact text of the first related error message, if any:

Please DO NOT include lists of local variables or installed addons, even if they are shown with the error message in-game!
N/A

Screenshot, if the problem is graphical:

Attach images to your ticket, or upload them and paste the URLs here.
N/A

Anything else you think might be helpful:

For BGs and LFR in particular I was wondering if it would be possible for a toggle-able option that stops forcing updates on Out of Range units to prevent performance related issues from occurring. In raids and battlegrounds I happen to experience a lot of performance issues related to the high demand of 25-40 man raids. I use multiple profiles depending on what environment I'm healing in, such as Alterac Valleys where I have all 3rd party Grid plug-ins disabled (in status and not just indicators and in Addon Control Panel too.), disable any statuses that I don't use (and even some that I do use, such as incoming heal, but performance decreases with this enabled is to be expected) just to improve my performance slightly and I was just wondering if this was a feasible implementation for anybody else who has this issue so that an alternative profile can help fix the solution and disabling Out of Range updates and hopefully benefit in performance.
I'd like to add that the reason why I believe my performance issues to be due to Grid is because of the fact that with Grid disabled I am able to play without any issues, however I enjoy your Add-On very much and find it incredibly helpful and therefore I would like to put this forward as a suggestion.

My apologies if this request is similar to any existing requests, impossible or if it's completely out of the question. I'm no expert in this field.
Thank you for your time, kind regards
dual1ty

User When Change
Phanx Dec 23, 2013 at 13:26 UTC Changed status from Replied to Duplicate
Phanx Dec 06, 2013 at 12:33 UTC Changed status from Waiting to Replied
dual1tyx Dec 06, 2013 at 07:45 UTC Changed description:
  #### **Does the problem still happen after you switch to a new profile in Grid with default settings, log out, and log back in?**
  *If not, please attach your Grid saved variables file to your ticket, and TELL US WHICH PROFILE you were using when the problem happened.*
- Yes
+ Yes, I use a variation of the default with 100% width, center text 2, and status indicators for my Riptide, Earth Shield, Water Shield, Earthliving and other shaman buffs and healing related information. All unnecessary statuses are disabled even those that are, such as Incoming Heal.
  #### **Exact text of the first related error message, if any:**
----------------------------------------
  #### **Anything else you think might be helpful:**
- For BGs in particular I was wondering if it would be possible for a toggle-able option that stops forcing updates on Out of Range units to prevent performance related issues from occurring. In raids and battlegrounds I happen to experience a lot of performance issues related to the high demand of 25-40 man raids. I use multiple profiles depending on what environment I'm healing in, such as Alterac Valleys where I have all 3rd party Grid plug-ins disabled (in status and not just indicators) just to improve my performance slightly and I was just wondering if this was a feasible implementation for anybody who uses more than one profile, so that they can disable Out of Range updates and hopefully benefit in performance.
+ For BGs and LFR in particular I was wondering if it would be possible for a toggle-able option that stops forcing updates on Out of Range units to prevent performance related issues from occurring. In raids and battlegrounds I happen to experience a lot of performance issues related to the high demand of 25-40 man raids. I use multiple profiles depending on what environment I'm healing in, such as Alterac Valleys where I have all 3rd party Grid plug-ins disabled (in status and not just indicators and in Addon Control Panel too.), disable any statuses that I don't use (and even some that I do use, such as incoming heal, but performance decreases with this enabled is to be expected) just to improve my performance slightly and I was just wondering if this was a feasible implementation for anybody else who has this issue so that an alternative profile can help fix the solution and disabling Out of Range updates and hopefully benefit in performance.
  I'd like to add that the reason why I believe my performance issues to be due to Grid is because of the fact that with Grid disabled I am able to play without any issues, however I enjoy your Add-On very much and find it incredibly helpful and therefore I would like to put this forward as a suggestion.
  My apologies if this request is similar to any existing requests, impossible or if it's completely out of the question. I'm no expert in this field.
Phanx Dec 06, 2013 at 07:38 UTC Changed status from New to Waiting
dual1tyx Dec 06, 2013 at 06:57 UTC Changed description:
  #### **Steps to reproduce the problem:**
- Be in a 25+ man raid.
+ Be in a 25+ man raid. LFR, BGs and guild raids.
  #### **What you expected to happen:**
dual1tyx Dec 06, 2013 at 06:55 UTC Changed description:
-
  #### **Grid version:**
  *Check the addon’s TOC file if you’re not sure!*
  5.4.1.1628
----------------------------------------
  #### **Anything else you think might be helpful:**
- For BGs in particular I was wondering if it would be possible for a toggle-able option that stops forcing updates on Out of Range units, to prevent performance related issues from occurring. In raids and battlegrounds I happen to experience a lot of performance issues related to the high demand of 25-40 man raids. I use multiple profiles depending on what environment I'm healing in, such as Alterac Valleys where I have all 3rd party Grid plug-ins disabled (in status and not just indicators) just to improve my performance slightly and I was just wondering if this was a feasible implementation for anybody who uses more than one profile, so that they can disable Out of Range updates and hopefully benefit in performance.
+ For BGs in particular I was wondering if it would be possible for a toggle-able option that stops forcing updates on Out of Range units to prevent performance related issues from occurring. In raids and battlegrounds I happen to experience a lot of performance issues related to the high demand of 25-40 man raids. I use multiple profiles depending on what environment I'm healing in, such as Alterac Valleys where I have all 3rd party Grid plug-ins disabled (in status and not just indicators) just to improve my performance slightly and I was just wondering if this was a feasible implementation for anybody who uses more than one profile, so that they can disable Out of Range updates and hopefully benefit in performance.
  I'd like to add that the reason why I believe my performance issues to be due to Grid is because of the fact that with Grid disabled I am able to play without any issues, however I enjoy your Add-On very much and find it incredibly helpful and therefore I would like to put this forward as a suggestion.
  My apologies if this request is similar to any existing requests, impossible or if it's completely out of the question. I'm no expert in this field.
- Thank you for you time, kind regards
+ Thank you for your time, kind regards
  dual1ty
dual1tyx Dec 06, 2013 at 06:53 UTC Changed description:
- > Please DELETE THIS LINE, fill in ALL of the information below, and change the Markup Type option to “Markdown”. Thanks!

  #### **Grid version:**
  *Check the addon’s TOC file if you’re not sure!*
dual1tyx Dec 06, 2013 at 06:52 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 7 comments
  • Avatar of Phanx Phanx Dec 23, 2013 at 13:26 UTC - 0 likes

    Closing this as a duplicate of #714:
    http://www.wowace.com/addons/grid/tickets/714-low-fps-in-healer-look-within-phase-on-norushen/

  • Avatar of dual1tyx dual1tyx Dec 07, 2013 at 18:05 UTC - 0 likes

    It sounds rather similar indeed. While I'm aware that it's no more expensive in resources, it is most certainly unnecessary for Grid to be updating these frames in an environment like Alterac Valley and other BGs or in raid encounters such as Galakras / Spoils of Pandaria in SoO, where you are never in range with everybody in the group, therefore disabling their updates for such units could be beneficial in such a case.

    The main encounters I'm having this with are Immerseus, Sha of Pride, Galakras and only on my healer, where Grid is being used. The fps remains low for the entire encounter essentially or until the healing and raid damage taken calms down a bit then instantly it's back with no problems and at least somewhere closer to the original 40fps. No joining, leaving or teleporting occurring, just a tonne of heals and damage being taken by the raid, as you would expect in 25-40 mans. Initially I thought this might be a graphics issue on my part, but after changing to a more recent card and turning all of my settings to Low I realised that it certainly was not that at fault, as only disabling Grid seemed to fix the problem.

    Last edited Dec 07, 2013 by dual1tyx
  • Avatar of Phanx Phanx Dec 07, 2013 at 13:08 UTC - 0 likes

    Based on your latest description of FPS dropping to single digits, I suspect you're having the same problem as the people in ticket #714, which seems to be caused by units being out of phase with you, not out of range. Without knowing which specific battleground(s) or raid encounter(s) you're having a problem with, or other details (is everyone in the raid group in the zone? does FPS stay low forever, or does it drop and then recover? if it's not constant, what's happening when it drops? did someone join the group? leave the group? did you use a teleport? etc.) it's hard to say anything conclusively.

    As for the rest, Grid doesn't just blindly update everything over and over. It only updates, for example, a unit's health bar when WoW tells Grid that that unit's health has changed. Range is not a factor -- if the game is telling the UI about an event (such as "this unit's health changed" or "this unit's auras changed") then it isn't any more "expensive" to get information about it (such as "how much health does this unit have?") and update the corresponding bar, icon, or text on Grid for a unit that's across the map than it does for a unit that's right next to you. If the unit is too far away to get a particular piece of information about (such as "did I cast this buff on this unit?") then Grid is already not updating that status, because WoW isn't telling it when that information is changing.

  • Avatar of dual1tyx dual1tyx Dec 06, 2013 at 17:12 UTC - 0 likes

    Once again I apologise, I posted it before work, I didn't expect your response to be so quick and as for vagueness, I'm not used to filing such reports so the level of detail may not be great. I haven't edited my ticket since then, which as far as I was aware you hadn't replied at which point. As I have said, I did try disabling them as well as their statuses and the performance wasn't much better. When I refer to performance or any kind of lag, I am referring to a drop of 40fps to fluctuating around 2fps. My suggestion was, that there be a way of turning off updates (e.g health, incoming heals, and other status indicators) for out of range units in 25-40 man raids/ battlegrounds, as while helpful, in a that environment are very costly in performance. I believe that it's not necessarily the out of range units per se, but the 20-40 man frames themselves and the sheer amount of things being done on them which I believe is not helped by the fact that Grid is monitoring all that happens to out of range units, it was just a suggestion that such actions should be toggle-able. I'd like to add that this is a problem I don't have in 10-15 man raids (with 3rd party plugins). I realise the title of my ticket didn't accurately reflect that if at all.

    Last edited Dec 06, 2013 by dual1tyx
  • Avatar of Phanx Phanx Dec 06, 2013 at 12:33 UTC - 0 likes

    Apologies are all well and good, but if you don't answer any of the questions I asked, what do you expect me to do? It looks like you've edited your ticket again, but if you added the answers to the questions I asked in my first reply, I'm not seeing them. Editing over and over is probably why your ticket is so disjointed in the first place. At this point if you have anything to add, please just post a comment so I can actually see what you're adding without having to pore over the poorly-formatted (Curse's fault, not yours) changelog.

  • Avatar of dual1tyx dual1tyx Dec 06, 2013 at 07:45 UTC - 0 likes

    Apologies, I've edited this so many times. Just want to make sure I've been as thorough as possible.

  • Avatar of Phanx Phanx Dec 06, 2013 at 07:38 UTC - 0 likes

    (1) Disabling the statuses provided by third-party plugins is not the same as disabling the plugin. Plugins may still be processing events, running continuous scripts, etc. even when their statuses are disabled.

    (2) I'm not sure what you mean by a "25-40 man toggle option" -- you can already switch between 25-player and 40-player layouts in Grid's options, and you can already use profiles to use different Grid setups for different group types/sizes/situations. If you're wanting some other type of option to do something else, please be more specific.

    (3) Aside from that your ticket seems to be mixing several different complaints/requests together, and it's all very vague. "Lag" in particular doesn't really tell me anything. What is "lagging"? Unit health updates on Grid? Your framerate? Mouse cursor movement? Chat input? How much is it "lagging" vs when Grid is disabled? (For example, if you're considering a drop of 5 FPS "a lot" I would disagree, and say that's unavoidable, but if there's a 50 FPS difference then that is clearly a problem.) What makes you think the problem is related to units being out of range?

  • 7 comments

Facts

Last updated
Dec 23, 2013
Reported
Dec 06, 2013
Status
Duplicate - This report duplicates an existing ticket.
Type
Enhancement - A change which is intended to better the project in some way
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees