Grid

714 - Low FPS when units are out of phase/not visible

Grid version:

5.3.0.1621

WoW version and region/language:

5.4 (17399) x64 enUS

Character race, class, spec, and level:

Blood Elf Holy Paladin level 90

Steps to reproduce the problem:

  1. Enter "Look Within" realm during Norushen encounter in Siege of Orgrimmar raid

What you expected to happen:

30+ FPS as is normal for me in raids

What actually happened:

Frame rate dropped to 1-2, making game pretty much unplayable

Does the problem still happen when all other addons — including all Grid plugins — are disabled?

I believe so.

Does the problem still happen after you switch to a new profile in Grid with default settings, log out, and log back in?

Unknown, difficult to test

Exact text of the first related error message, if any:

None

Screenshot, if the problem is graphical:

n/a

Anything else you think might be helpful:

There have been several forum threads on various forums, with many healers concurring that they have this problem and that it is caused by Grid. Google "Norushen fps" to see them.

User When Change
Phanx May 07, 2014 at 05:00 UTC Changed status from Waiting to Fixed
Phanx Jan 06, 2014 at 08:55 UTC Changed status from Started to Waiting
Phanx Jan 01, 2014 at 03:43 UTC Changed name from Low fps in healer "Look Within" phase on Norushen to Low FPS when units are out of phase/not visible
Phanx Jan 01, 2014 at 03:42 UTC Changed status from Replied to Started
slybootz Oct 08, 2013 at 19:16 UTC Changed status from Waiting to Replied
Phanx Oct 08, 2013 at 06:47 UTC Changed status from Replied to Waiting
slybootz Oct 03, 2013 at 15:10 UTC Changed status from Waiting to Replied
Phanx Oct 03, 2013 at 05:46 UTC Changed status from Replied to Waiting
Alberto34 Sep 29, 2013 at 12:47 UTC Changed status from Waiting to Replied
Phanx Sep 29, 2013 at 00:10 UTC Changed status from New to Waiting
Gronzig Sep 28, 2013 at 18:18 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of Phanx Phanx Jan 06, 2014 at 08:54 UTC - 0 likes

    Need people who are experiencing this issue to volunteer to test some alpha versions. If you know how to check out from SVN and are able to follow instructions and provide prompt feedback, please do the following:

    1. Check out the latest revision from SVN.
    2. Disable all other addons (ideal) or at least all Grid plugins.
    3. Go do whatever content kills your FPS (Norushen, Alterac Valley, etc.).
    4. Report back with the results.

    Please do not bother posting if:

    • you do not know how to use SVN,
    • you do not experience the FPS issue described in this ticket,
    • you are going to take weeks to check back for replies, or
    • you are not willing to disable any and all Grid plugins during testing.
  • Avatar of lhyaran lhyaran Dec 04, 2013 at 06:03 UTC - 0 likes

    Sorry if this has been covered.

    The FPS seems to be more of an out of range factor for the rest of the raid. I've noticed in raids, that if I'm out of the instance when they do a boss (but in raid) my FPS drops. I just did a world boss then where I wasn't phased with everyone else, was by myself when they pulled, my FPS when down to 2 or 3. Everyone's frames where marked as out of range, but as soon as I left group, my FPS returned to normal.

    I Norushen, when you phase into realm by yourself, everyone's frames come up as ouut of range.

    L.

  • Avatar of Winney1907 Winney1907 Nov 30, 2013 at 21:18 UTC - 0 likes

    Only just seen this but the lag is caused by GridStatusHots and not Grid. Myself and 3 other guild mates all had this lag then it went away as soon as we disabled GridStatusHots (which isn't even needed anymore).

  • Avatar of Phanx Phanx Nov 06, 2013 at 01:09 UTC - 0 likes

    Without manually editing the files to output only the debug messages you want to see, no.

    However, if you're feeling adventurous, it could be helpful to comment out the reference to Statuses\Statuses.xml in the TOC file, so no status modules even get loaded. This would definitively rule out all statuses as the cause of the problem, though you would need to have the default raid frames shown alongside Grid in order to see anyone's health etc.

  • Avatar of sampo23 sampo23 Nov 05, 2013 at 16:58 UTC - 0 likes

    I have had this same framerate problem in LFR norushen every time i've ever done it (i usually just resolve to the fact that i will die in the healer alternate world). I am going to test the disabling of incoming heal later today, but i just wanted to let you know that I DO run swatter and it shows no errors logged during the time period yesterday i was in the norushen encounter.

    Is there a way to enable greater granularity of logging that i could turn on?

  • Avatar of Phanx Phanx Nov 05, 2013 at 13:03 UTC - 0 likes

    I came across an unrelated posting noting that UnitPower is bugged for the Norushen encounter. This may or may not be relevant. If anyone is still doing this encounter, please enter the following commands twice during the fight (once in the Look Within realm, and once out of it) and let me know what gets printed to your chat frame each time:

     /run print("player", UnitPower("player"), "raid7", UnitPower("raid7"))
    

    No, "raid7" isn't significant, it's just a random unit that's not the player, but will always exist in a raid.

    Also, I was looking over this thread, and realized I never actually asked -- are you guys all running BugSack or Swatter? Otherwise, there may actually be error messages pinpointing the exact cause of the problem, and you're just not seeing them because you don't have an error handler running.

    Last edited Nov 05, 2013 by Phanx
  • Avatar of andyf andyf Oct 17, 2013 at 02:57 UTC - 0 likes

    @Phanx: Go

    I just went in to the encounter in LFR, with almost all statuses disabled. I only had the following active:

    Health ReadyCheck Target Marker Player Target Marker Player Target Your Target

    Every other status was disabled, including Names, RangeCheck, and Raid Debuffs.

    My FPS still dropped to 1 when I went into the personal trial portion, and my inputs were extremely laggy (as others have reported). The lag seemed somewhat lessened compared to leaving all the statuses active, but it was still a major fps drop with extreme input lag.

    Turning off Grid (after the wipe) and turning on Blizz raid frames gave me full fps during the personal trial.

    Hope this helps; if there's any other data I can collect, let me know.

    Last edited Oct 17, 2013 by andyf
  • Avatar of Phanx Phanx Oct 15, 2013 at 12:09 UTC - 0 likes

    I do not have an ETA. I haven't personally been active in raiding since WotLK, and don't have any characters at 90 geared enough to get into any newer LFRs, so until someone who actually has access to the Norushen encounter can provide some feedback that makes it obvious what's causing the problem, there's not a whole lot I can do, and none of the other people who have helped out with this kind of content-specific bugfixing in the past seem to be around anymore.

    If you want to help, you can keep disabling statuses each time you do the encounter, to try to narrow down which one(s) are causing the problem. Based on the one report I got, disabling the Incoming Heals status helped, but didn't completely eliminate the freeze. If you want to run Grid alongside some other addon (or even the default UI) it may be most effective to start out by disabling *all* statuses except for the most basic ones (unit name, unit health) and try enabling a few at a time.

    Also, remember to disable statuses in the Status menu, rather than just un-assigning them from indicators.

  • Avatar of mboisso mboisso Oct 15, 2013 at 11:41 UTC - 0 likes

    Have you identified the source of this bug from the data reported by Slybootz and me ? Can we expect a fix soon, or should we start moving to another healing addon :/ ?

  • Avatar of Spartan069 Spartan069 Oct 08, 2013 at 22:53 UTC - 0 likes

    @Phanx

    I only use 1 default profile for all my characters. I never switch it because i have it setup to show exactly what I want for all classes. I'm sad to say it, but disabling grid and using vuhdo is working just fine for me. Unfortunately with my current work schedule I have very little time to help troubleshoot outside of that. If there is anything i can run/log and upload that would help let me know.

Facts

Last updated
May 07, 2014
Reported
Sep 28, 2013
Status
Fixed - Developer made requested changes. QA should verify.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
2

Reported by

Possible assignees