Grid

713 - Out of Range Status not handling Pets in Solo.

Grid version:

5.3.0.1621

WoW version and region/language:

5.3.0 (17128) (Release x64) - US/English [Running on Mac client if that matters]

Character race, class, spec, and level:

Draenei, Mage, Frost, 90

Steps to reproduce the problem:

  1. Log in to character with aforementioned Grid enabled outside of group.
  2. Ensure Solo Layout is set to show pets (I'm using By Group 5 w/ Pets).
  3. Have Out of Range status set to reflect on Frame Alpha Indicator.
  4. Observe my summoned Water Elemental, "standing" a yard away from me, is faded as out of range on my Grid.
  5. Dismiss and resummon Water Elemental. Still OOR.
  6. Invite someone to a party. Water Elemental suddenly appears in range. Behavior after this seems erratic. Sometimes pet OOR tracking seems
    to keep working after party is disbanded. Not always.

What you expected to happen:

Expecting OOR status to be meaningful on pets even in solo.

What actually happened:

OOR status on pets appears not to be working in solo.

Does the problem still happen when all other addons — including all Grid plugins — are disabled?

Affirmative. Disabled everything except Grid core and retested. Same result.

Does the problem still happen after you switch to a new profile in Grid with default settings, log out, and log back in?

Affirmative. Switched to an unused profile. Mashed reset to default. After reconfiguring solo layout to "By Group 5 w/ Pets", elemental was
OOR again.

Exact text of the first related error message, if any:

N/A

Screenshot, if the problem is graphical:

**Note -> I took these before disabling all addons and resetting the Grid profile.

Solo: http://imgur.com/7DeXmCj

Grouped: http://imgur.com/FltiweL

Anything else you think might be helpful:

I started seeing this only after updating up to release 1621. I think I was previously on 1600 (5.2.0 release).
PM me if I can provide any further info / testing.

User When Change
Phanx Dec 23, 2013 at 13:28 UTC Changed status from Replied to Invalid
hshh Sep 24, 2013 at 07:34 UTC Changed status from Waiting to Replied
Phanx Aug 29, 2013 at 23:31 UTC
scubamonkey Aug 28, 2013 at 14:16 UTC
Phanx Aug 26, 2013 at 08:15 UTC Changed description:
  #### **Screenshot, if the problem is graphical:**
  **Note -> I took these before disabling all addons and resetting the Grid profile.

- Solo:               http://imgur.com/7DeXmCj
+ Solo:               <http://imgur.com/7DeXmCj>
- Grouped:         http://imgur.com/FltiweL
+ Grouped:         <http://imgur.com/FltiweL>
  #### **Anything else you think might be helpful:**
Phanx Aug 26, 2013 at 05:58 UTC
scubamonkey Aug 24, 2013 at 19:01 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 7 comments
  • Avatar of Phanx Phanx Dec 23, 2013 at 13:28 UTC - 0 likes

    Marking as Invalid since I cannot reproduce the problem or see any obvious cause for it in the code. If anyone is still having this problem, please provide the relevant debug messages as described in previous comments.

  • Avatar of Phanx Phanx Nov 30, 2013 at 17:26 UTC - 0 likes

    That isn't a fix; it just breaks the function by feeding the wrong arguments to the wrong lines of code, resulting in always using the (much more expensive) group range check. Feel free to verify that the existing arguments are correct with a print statement.

    Anyway, I could not reproduce any issue with solo pet range checking on either a warlock or a hunter, either before, during, or after being in a group. In every case the debug messages correctly identify the group state, and indicate that the range checker is correctly switching modes.

  • Avatar of hshh hshh Sep 24, 2013 at 07:34 UTC - 0 likes

    Modify GridStatusRange.lua Search function GridStatusRange:PartyTransition(message, state, oldstate) Replace to function GridStatusRange:PartyTransition(state, oldstate)

    This is fix for solo mode

  • Avatar of Phanx Phanx Aug 29, 2013 at 23:31 UTC - 0 likes

    Keep an eye on it and let me know what debugging messages you get when you leave a party and your pet gets flagged as out of range -- the only thing I can think of is that it's somehow getting stuck in "group range check" mode, which will fail when you're not in a group, but I'm not really sure how that would be happening...

  • Avatar of scubamonkey scubamonkey Aug 28, 2013 at 14:16 UTC - 0 likes

    1. GridStatusRange debugging enabled.

    2. Standing around solo, pet next to me, but showing out of range, result of running /dump UnitInRange("pet"):
    false, false.

    3. Form a party yields result:
    GridStatusRange: PartyTransition party
    GridStatusRange: StartTimer CheckRange 0.2 true nil
    GridStatusRange: StopTimer CheckRange
    (Pet now shows in range on Grid)

    4. Rerun /dump UnitInRange("pet"):
    true, true

    5. Dropping party result:
    GridStatusRange: PartyTransition solo
    GridStatusRange: StopTimer CheckRange
    (Pet continues to show as in range)

    6. Rerunning /dump UnitInRange("pet") now that we're back outside party:
    false, false
    (Note, interestingly, pet is still showing in range on Grid)

    Last edited Aug 28, 2013 by scubamonkey
  • Avatar of Phanx Phanx Aug 26, 2013 at 05:58 UTC - 0 likes

    Please enable debugging for GridStatusRange (/grid > Debug tab) and watch for "PartyTransition" messages when you join or leave a group. If you notice it saying anything other than "solo" when you've left a group, please let me know.

    Also, next time you see this happen, please type this command and let me know what gets printed to your chat frame:

    /dump UnitInRange("pet")
    
  • Avatar of scubamonkey scubamonkey Aug 24, 2013 at 19:02 UTC - 0 likes

    I think this is old ticket 627 re-appearing, btw.

  • 7 comments

Facts

Last updated
Dec 23, 2013
Reported
Aug 24, 2013
Status
Invalid - This was not a valid report.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees